N610 crash adding entry into address book [@ nsAbMDBDirectory::AddCard]

VERIFIED DUPLICATE of bug 91594

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
VERIFIED DUPLICATE of bug 91594
17 years ago
13 years ago

People

(Reporter: greer, Assigned: chuang)

Tracking

({crash, topcrash})

Trunk
x86
Windows 98
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
N6.10 is crashing on some users who try to add addresses into their personal 
address book. 

Stack Trace:

         nsAbMDBDirectory::AddCard
[d:\builds\seamonkey\mozilla\mailnews\addrbook\src\nsAbMDBDirectory.cpp  line
685]
         nsAbCardProperty::AddCardToDatabase
[d:\builds\seamonkey\mozilla\mailnews\addrbook\src\nsAbCardProperty.cpp  line
793]
         XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp 
line 139]
         XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp  line
1883]
         XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp 
line 1253]
         js_Invoke      [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 
809]
         js_Interpret   [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 
2703]
         js_Invoke      [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 
825]
         js_InternalInvoke      [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  
line 897]
         JS_CallFunctionValue   [d:\builds\seamonkey\mozilla\js\src\jsapi.c  
line 3322]
         nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp  line 944]
         nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp  line 140]
         nsXBLPrototypeHandler::ExecuteHandler
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeHandler.cpp  line
432]
         nsXBLWindowHandler::WalkHandlersInternal
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLWindowHandler.cpp  line 310]
         nsXBLWindowKeyHandler::WalkHandlers
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLWindowKeyHandler.cpp  line
132]
         nsXBLWindowKeyHandler::KeyPress
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLWindowKeyHandler.cpp  line
148]
         nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp  line
1598]
         nsXULDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp  line
2020]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3662]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line
3654]
         nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp  line 1696]
         nsHTMLInputElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLInputElement.cpp 
line 1083]
         PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5569]
         PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5496]
         nsView::HandleEvent    
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line
377]
         nsView::HandleEvent    
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line
350]
         nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 2056]
         HandleEvent    [d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 
68]
         nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 724]
         nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 741]
         nsWindow::DispatchKeyEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 2390]
         nsWindow::OnChar       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp 
line 2515]
         nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 3508]
         nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 989]
         KERNEL32.DLL + 0x363b (0xbff7363b)
         KERNEL32.DLL + 0x24407 (0xbff94407)
         0x0068824e
(Reporter)

Comment 1

17 years ago
Created attachment 45523 [details]
User comments for this crash
(Reporter)

Updated

17 years ago
Keywords: crash, topcrash

Comment 2

17 years ago
This looks like it might be a duplicate of:

http://bugzilla.mozilla.org/show_bug.cgi?id=91594

which has already been fixed in mozilla.

Updated

17 years ago
QA Contact: fenella → nbaca

Comment 3

16 years ago
thanks john, this does look like a dup.  marking it so.

*** This bug has been marked as a duplicate of 91594 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Crash Signature: [@ nsAbMDBDirectory::AddCard]
You need to log in before you can comment on or make changes to this bug.