Closed Bug 948945 Opened 7 years ago Closed 7 years ago

Datastore API is not storing / returning string arrays correctly

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jmcf, Assigned: baku)

Details

Attachments

(1 file)

Attached file tdatastore.zip
Datastore is not storing / return properly strings arrays. 

See attached test case.
Summary: Datastore API is not returning string arrays correctly → Datastore API is not storing / returning string arrays correctly
Assignee: nobody → amarchesini
just adding other people I know are using the Datastore ...
In the test it seems that the problem is that var 'name' is out of scope.
You create it in the first success() function, and then you use it in another function.

Can this be your problem?
Flags: needinfo?(jmcf)
oh yes. A terrible mistake :(. I'm trying to catch a regression with FB Contacts and for some reason I was blaming Datastore and my erroneous test was a false positive of my suspects. It seems it is a mozContact problem.

Sorry for the inconvenience
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(jmcf)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.