Firefox 26.0 mini-dumps with McAfee SiteAdvisor Enterprise 3.5 which hides from it

RESOLVED INVALID

Status

()

Firefox
Untriaged
--
major
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: k1devnull, Unassigned)

Tracking

26 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

1. Update to Firefox 26.0
2a. (menu) Firefox-Add-ons
2b. (menu) Firefox-Help-Restart with Add-ons Disabled
2c. (address) about:config



Actual results:

1. Firefox freezes
2. Popup message:
"SiteAdvisor Enterprise may be busy ..."
3. Firefox creates mini dumps

SiteAdvisor Enterprise does not show in Add-ons tabs after mini dump completes.  It does show in about:plugins

SiteAdvisor Enterprise

    File: NPMcFFPlg.dll
    Path: C:\Program Files (x86)\McAfee\SiteAdvisor Enterprise\NPMcFFPlg.dll
    Version: 3.5.0.724
    State: Enabled
    SiteAdvisor

In safe mode, SiteAdvisor plugin is still active.

SiteAdvisor hiding from Firefox has been around for since middle of 2013.  But the current problem with Firefox 26.0 has been the most severe mis-behavior.



Expected results:

* No Firefox freezes or mini dumps.
* SiteAdvisor shows in add-ons tabs and be under Firefox control (i.e. completely disable.)
(Reporter)

Updated

4 years ago
Severity: normal → major
(Reporter)

Updated

4 years ago
Crash Signature: mini dump

Comment 1

4 years ago
Hi,
I can confirm the issues w/ FF26 and SiteAdvisor Enterprise 3.5.0 latest. FF25 worked, so does FF27 beta, looks like only 26 has the issue. Same behavior as above: 
1. Firefox freezes
2. Popup message: "SiteAdvisor Enterprise may be busy ..."
3. If chosing "continue" goto 1. else
4. If chosing kill plugin FF26 works OK but IE doesn't work anymore, looks like the SAE hangs even if the task manager shows it running

Multiple users reported the same thing, given the fact that it worked w/ FF25 and it works w/ FF27b my suspicion is with FF26.

Please see the McAfee Community forums for details: https://community.mcafee.com/thread/62978?tstart=0
I also have an SR open w/ McAfee but from their perspective it all seems OK. I hope this helps, pelase keep me posted w/ status
Thanks,
Tudor
(Reporter)

Comment 2

4 years ago
McAfee perspective it all seems OK is probably their standard answer.  I did find SiteAdvisor crash
core log files:

C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_McSACore.exe_324e7fe64642327c563be75ae6b82beb2b8c1adb_cab_1173d844\Report.wer	12 KB
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_McSACore.exe_324e7fe64642327c563be75ae6b82beb2b8c1adb_cab_1173d844\WERD299.tmp.appcompat.txt	58 KB
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_McSACore.exe_324e7fe64642327c563be75ae6b82beb2b8c1adb_cab_1173d844\WERD597.tmp.WERInternalMetadata.xml	3 KB
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_McSACore.exe_324e7fe64642327c563be75ae6b82beb2b8c1adb_cab_1173d844\WERD5A7.tmp.hdmp	3,472 KB
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_McSACore.exe_324e7fe64642327c563be75ae6b82beb2b8c1adb_cab_1173d844\WERD7DA.tmp.mdmp	894 KB

Although Firefox 25 did not have this plugin failures, it and previous Firefox versions had other misbehavior (hiding from Firefox, can not control from Firefox, plugin button display problem, etc.)  It does behave like a malware.

Comment 3

4 years ago
Hi
Looks like FF27b1 has the same issues, after some joy yesterday, had the same issues this AM. Now I am back to FF25.0.1 which seems to be working ok for now. BTW, my dumps as as old as my upgrade to FF26, 12/11.
Thanks

Comment 4

4 years ago
Hi Guys,
I can confirm this error too. Firefox working after plugin stopped but the IE freezes after this method.

I found the following link - how to resolve the problem, but I don't want to delete the advisor.
https://kc.mcafee.com/corporate/index?page=content&id=KB79967&actp=LIST_RECENT
It's fun that the solution from Mcafee is to remove their product..
"Remove SAE until a future product release"

Comment 5

4 years ago
Hi Guys,

I installed the 27.0b9 without administration rights - The Fox is working without any popup messages and the IE is working too.
I checked the additionals and found the SiteAdvisor in blocked mode. - I red that some versions of McAfee SiteAdvisor are already on the Add-ons Blocklist. I use the latest version of Siteadvisor 3.5.0.724. So it's seems that they "resolved" the issue..
(Reporter)

Comment 6

4 years ago
To uninstall SiteAdvisor, had to delete registry entry for SiteAdvisor Service.  Otherwise, that service
prevents uninstall.
marking invalid because this seems to be caused by a third party extension and this report is about an old version.
I guess that this works now
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.