Statistics page is not displayed correctly (Hanger)

RESOLVED FIXED in 2014-01-14

Status

Marketplace
Statistics
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: karina.filipe, Assigned: robhudson)

Tracking

2014-01-14
Points:
---

Details

(Whiteboard: [incorrect_implementation])

Attachments

(2 attachments)

89.42 KB, image/png
Details
145.56 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
(Reporter)

Description

4 years ago
Created attachment 8345947 [details]
Untitled.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131112160018

Steps to reproduce:

1. Enter https://marketplace.allizom.org/statistics/app/facebook
2. Login
3. Click on "statistics" for the Facebook app
4. Page https://marketplace.allizom.org/statistics/app/facebook will load


Region code: Hanger
Device: Browser
Connection: Wi-Fi
Phone number/MSISDN: -
Carrier: -



Actual results:

The page does not load any content


Expected results:

The statistics page should load correctly

Updated

4 years ago
Component: Payments/Refunds → Statistics
The app itself (on stage) has no data (all the results return 'null') and this used to generate a JS error that caused the page to halt execution. This has since been fixed but the app will still show no data.

Not sure which specific commit addressed this but I can do a deeper dig if anyone needs the commit hash.
Assignee: nobody → dspasovski
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Priority: -- → P2
Resolution: --- → FIXED
Target Milestone: --- → 2014-01-14

Comment 2

4 years ago
Data is not listed for apps which are bought daily as part of the test process. See https://marketplace.allizom.org/statistics/app/pricepoint1-010/installs/?start=2013-02-01&end=2014-01-13&region=us
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Assignee: dspasovski → robhudson.mozbugs
(Assignee)

Comment 3

4 years ago
I double checked the date formatting of the log file that solitude writes and everything is lining up correctly there. I'll dig a little further along the code path to see where/why things are failing.
(Assignee)

Comment 4

4 years ago
I couldn't find anything wrong with the logic. All the data seems to be available. But for some reason it isn't being recorded in monolith.

We re-ran the aggregator on stage and data populated fine. We could do the same for prod. I'll watch for the nightly runs to see if they start working.
(Assignee)

Comment 5

4 years ago
The original issue reported works for me. The page displays fine.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME

Comment 6

4 years ago
Created attachment 8363873 [details]
Print_Bug 948989.docx

Comment 7

4 years ago
The page still does not display statistics
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

4 years ago
Same problem here. In the developer console, Chrome try to connect to URL like "https://marketplace.firefox.com/api/v1/apps/app/[APP_NAME]/?_user=..." but get {"detail":"Internal Server Error"} with 500 error code.

Updated

4 years ago
Whiteboard: [incorrect_implementation]
(Assignee)

Comment 9

4 years ago
Testing this today I get "No public statistics are available" from a user in the Hanger region. Since this app's stats are not publicly viewable this is correct.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.