[B2G][Contact] Cancelling link contact retry screen does not reconnect or give an option to go back.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: jharvey, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g18 unaffected, b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

Attachments

(2 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

5 years ago
[B2G][Contact] Canceling link contact retry screen does not reconnect or give an option to go back.

Description:
When the user presses link contact after being connected to Facebook if they press cancel at the right time causes the "Unable to connect, Tab to retry" screen appear but does not ever reconnect or is there an option to go back. 

Repro Steps:
1) Updated Buri 1.3 20131210004003
2) Sync to Facebook but don't add contacts.
3) Have at least one contact.
4) Select the Contacts app.
5) Select one of the contacts.
6) Select link contact.
7) Just before connecting, cancel.

Actual:
"Unable to connect" screen pops up that never connects even after taping retry and there is no option to go back to contacts.

Expected:
After selecting retry, the app reconnects and has an option to go back.

Environmental Variables:
Device: (example: Buri v1.2 Mozilla RIL)
BuildID: 20131210004003
Gaia: 3452fbdb5e1bed0cd27cc6173136537a03e8072f
Gecko: e0c328d99742
Version: 28.0a2
status-b2g-v1.3: --- → affected
Summary: [B2G][Contact] Canceling link contact → [B2G][Contact] Canceling link contact retry screen does not reconnect or give an option to go back.
(Reporter)

Comment 2

5 years ago
Buri 1.2 seems to not have this screen ever pop up and pressing the cancel button just goes back to the previous screen.

Environmental Variables:
Device: Buri 1.2 Com Ril
BuildID: 20131209004003
Gaia: f615ae7acb6731d191b3094e10e314bc28359bbb
Gecko: f684b8f159a3
Version: 26.0
status-b2g18: --- → unaffected
Keywords: regression, regressionwindow-wanted
Summary: [B2G][Contact] Canceling link contact retry screen does not reconnect or give an option to go back. → [B2G][Contact] Cancelling link contact retry screen does not reconnect or give an option to go back.
(Reporter)

Comment 3

5 years ago
Created attachment 8346019 [details]
retrypopup.png
This needs more information. I'm also unsure this is a regression.

What happens if you time hitting the cancel button at different times during linking? Trying to get a sense of if this happens generally in that UI or if it needs to be well-timed.
Keywords: regression, regressionwindow-wanted → qawanted

Comment 5

5 years ago
German,

Please could you try to reproduce?
Flags: needinfo?(gtorodelvalle)
Hi guys, in fact I am not even able to get the retry page using Gecko-c8ebb7f and v1.3 Gaia as for now :\

jharvey, could you provide us more information about how to get the retry page (maybe some more screenshots would help)? In fact, when I click on the link button and get the "Please hold on. We are calculating a proposal.", if I click on the Cancel button, it seems to cancel fine :-)
Flags: needinfo?(gtorodelvalle) → needinfo?(jharvey)
(Reporter)

Comment 7

5 years ago
Created attachment 8346651 [details]
Retry.mpeg
Flags: needinfo?(jharvey)
(Reporter)

Comment 8

5 years ago
There is a timing to it, the user has to press cancel immediately before the next screen pops up.

Added attachment "Retry.mpeg"
(Reporter)

Updated

5 years ago
Keywords: qawanted
So this definitely looks like a regression because the UX here looks like it was part of the 1.3 visual refresh. The timing of this doesn't make me think this is a blocker, although more investigation here to see if this happens more commonly in other scenarios might be helpful.
status-b2g-v1.2: --- → unaffected
Keywords: regression, regressionwindow-wanted
Hi jharvey, thank you very much for your video. It really helped ;-) Anyhow, I am still not able to reproduce the issue in 1.3 using Gecko-6212fb5.Gaia-a99249a although I have tried to... a lot :-p Would you be so kind to retry it with the latest code from 1.3 and tell me if you reproduce it yet? :-)

Apart from this and as part of my analysis, I just confirmed that the "Tap to retry" is a system app message (see https://github.com/mozilla-b2g/gaia/blob/master/apps/system/net_error.html#L32) and not a Contacts app one :-O
Flags: needinfo?(jharvey)
(Reporter)

Comment 11

5 years ago
Hey Gtorodelvalle, I tried to reproduce the bug and it looks like its now working correctly on the latest 1.3 build.

Closing this bug as works for me.

Environmental Variables:
Device: Buri 1.3
BuildID: 20131220004001
Gaia: ee5560ab86103701a5d046ef31d46e6c1e026355
Gecko: 40c4cb09bce5
Version: 28.0a2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jharvey)
Resolution: --- → WORKSFORME

Updated

5 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.