[B2G][Bluetooth File Transfer][Music] Playback slider unmovable and causes audio issues while playing MP3 recieved by bluetooth transfer,

RESOLVED FIXED in 1.3 C2/1.4 S2(17jan)

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bzumwalt, Assigned: dkuo)

Tracking

({regression})

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox29 affected, b2g-v1.2 unaffected, b2g-v1.3 fixed)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8345988 [details]
Screenshot

Description:
While playing MP3 sent over bluetooth playback slider does not move when interacted with and causes other parts of song to play simultaneusly.

Repro Steps:
1) Updated Buri to Build ID: 20131211004003
2) Turn on bluetooth and pair to another device
3) Have paired device send .mp3 file via bluetooth transfer
4) Accept transfer request
5) Once transfer is complete, click on notification to open file
6) While file is playing move playback slider repeatedly

Actual:
Moving playback slider on bluetooth transferred .mp3 does not move from starting position and causes multiple parts of song to be played at once.

Expected:
Playback slider can be used on bluetooth transferred .mp3 without incident.

Environmental Variables
Device: Buri v 1.3 Mozilla RIL
Build ID: 20131211004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/6bb84d0bc170
Gaia: 7a2ccae2a546ac4d981d250272dafa630c926422
Platform Version: 28.0a2
Firmware Version: V1.2_US_20131115


Notes:
Repro frequency: 3/3, 100%
See attached: screenshot and video clip
(Reporter)

Comment 1

5 years ago
Issue occurs in today's 1.4 Buri build

Result: Moving playback slider on bluetooth transferred .mp3 does not move from starting position and causes multiple parts of song to be played at once.

Environmental Variables
Device: Buri v 1.4 Mozilla RIL
Build ID: 20131211040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/12ea03a70243
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Platform Version: 29.0a1
Firmware Version: V1.2_US_20131115
status-firefox29: --- → affected
Does this reproduce on 1.2?
Keywords: qawanted
(Reporter)

Comment 3

5 years ago
Issue does NOT reproduce in 1.2 on Buri

Result: Playback slider can be used on bluetooth transferred .mp3 without incident.

Environmental Variables
Device: Buri v 1.2 COM RIL
Build ID: 20131211004007
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/43d7b300241a
Gaia: 096722a9e2510ecdfe45ba7382d7d50826b82feb
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2_US_20131115
status-b2g-v1.2: --- → unaffected
Keywords: qawanted
blocking-b2g: --- → 1.3?
Component: Gaia::Bluetooth File Transfer → Gaia::Music
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
QA Contact: sparsons
(Assignee)

Updated

5 years ago
Assignee: nobody → dkuo

Comment 4

5 years ago
This issue started to occur on the Buri 1.3 Build ID: 20131122123502

Gaia   2cc78d696482e0434b584f5645af55e3105e59a2
SourceStamp 3c4fc4279e6a
BuildID 20131122123502
Version 28.0a1

Last working Buri 1.3 Build ID: 20131121040202

Gaia   71063dd91bc8cbb15ba335236ed67a1c5058bd58
SourceStamp cf378dddfac8
BuildID 20131121040202
Version 28.0a1
Keywords: regressionwindow-wanted

Comment 5

5 years ago
Tried the same issue on 2 Nexus 4. On Transferring image/audio(mp3) file from Phone 1 to Phone 2 , notification is received to accept the transfer. Click accept and Phone 2 restarts.

Also I noticed, that "Visible to all" turns off when pairing. Its a random behavior.

OS Version : 1.3.0.0-prerelease
Platform version: 29.0a1
Build Identifier : 20131213153944
Git Commit Info : 2013-12-13 03:54:27 a6c2af8d
Flags: needinfo?(bzumwalt)
(In reply to amitav.anand from comment #5)
> Tried the same issue on 2 Nexus 4. On Transferring image/audio(mp3) file
> from Phone 1 to Phone 2 , notification is received to accept the transfer.
> Click accept and Phone 2 restarts.
> 
> Also I noticed, that "Visible to all" turns off when pairing. Its a random
> behavior.
> 
> OS Version : 1.3.0.0-prerelease
> Platform version: 29.0a1
> Build Identifier : 20131213153944
> Git Commit Info : 2013-12-13 03:54:27 a6c2af8d

There really isn't a reason for the needinfo request here - clearing flag.
Flags: needinfo?(bzumwalt)

Comment 7

5 years ago
Bad experience if multiple parts of the song is being played when you move the slider. Marking this a blocker.
blocking-b2g: 1.3? → 1.3+

Comment 8

5 years ago
This issue is reproducible on ZTE device also. On receiving the mp3 file via BT, 2 instance on the music player is being created. The function showCurrentView is being called on receiving file via BT from musicdb.oncreated = function(event) in music.js file. 
Also saw the traces and saw 2 prints from OMX codec being created "Attempting to allocate OMX node 'OMX.qcom.audio.decoder.mp3'"
Analyzing more on this.
(Assignee)

Comment 9

5 years ago
Okay, I found the root cause and it's another regression that caused by bug 939139, the width style of the progress bar was removed.

This issue is reproduced by tapping on notification to open a received audio, so it's an open activity which uses the open.html in music app. The open.html includes different css files from index.html, and the width style of the progress bar is in "shared/style_unstable/progress_activity.css", which was not included in open.html and that's why the width of progress bar in open activity is 0.

The patch should be simply including "shared/style_unstable/progress_activity.css" in open.html, or assign width: 100% to #player-seek-bar-progress.
Depends on: 939139
(Assignee)

Comment 10

5 years ago
Created attachment 8355437 [details] [review]
include the missing css file in open.html

Jim,

This is the patch that includes progress_activity.css in the open.html to fix this issue, would you please review it? thanks.
Attachment #8355437 - Flags: review?(squibblyflabbetydoo)

Comment 11

5 years ago
(In reply to Dominic Kuo [:dkuo] from comment #10)
> Created attachment 8355437 [details] [review]
> include the missing css file in open.html
> 
> Jim,
> 
> This is the patch that includes progress_activity.css in the open.html to
> fix this issue, would you please review it? thanks.
Hi,
I tested the patch,it solves the progress bar issue but it seems there is one more issue with this bug.
Same song is being played twice. After Pausing one instance of the song from UI, we can hear one more instance of the song still being played in background.

I observed that, after the file is received via BT, when we click on the notification, control goes through bt_openReceivedFile in apps/system/js/bluetooth_transfer.js and this function is being called twice.

Even the window.addEventListener in apps/music/js/open.js is called twice which according to the function prototype should be called only on "localized" events. 

And handleOpenActivity in music/open.js is being called 4 times.
Still Analyzing it...
(Assignee)

Comment 12

5 years ago
I believe that's another issue because this patch only modified the css and html files, js files are not involved. Please file a new bug if the issue you mentioned in comment 11 still reproducible, let's trace and fix in the new bug, thanks.
(Assignee)

Comment 13

5 years ago
The issue that comment 11 mentioned is bug 956276, it's unrelated to my patch. Jim, while you are testing the patch, please note bug 956276 can cause 2-4 open activities at the same time, so probably you are unable to verify the patch if the open activity are not launched normally, let me know if you encounter that issue, thanks.

Updated

5 years ago
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 957940
jim, any update on the review?
Flags: needinfo?(squibblyflabbetydoo)
Comment on attachment 8355437 [details] [review]
include the missing css file in open.html

Sorry for the delay; this looks good! r=me
Attachment #8355437 - Flags: review?(squibblyflabbetydoo) → review+
Flags: needinfo?(squibblyflabbetydoo)
(Assignee)

Comment 17

5 years ago
Thanks Jim!

Landed on master: c75a943bb4c2ca329c01406211c4fe77186d49cb
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted c75a943bb4c2ca329c01406211c4fe77186d49cb to:
v1.3: ca0d5cd8715c0f2782e926da318fc0a396282266
status-b2g-v1.3: affected → fixed
You need to log in before you can comment on or make changes to this bug.