[B2G][Marketplace] Multiple applications (WP Photos, Poppit, Terra) don't launch correctly upon installing them from the Marketplace

RESOLVED DUPLICATE of bug 959941

Status

RESOLVED DUPLICATE of bug 959941
5 years ago
11 months ago

People

(Reporter: tnguyen, Unassigned)

Tracking

({regression})

29 Branch
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.4+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8346069 [details]
Screenshot

When the user launches WordPress Photos app they will be brought to the "Index of app..." instead of launching correctly.

Repro Steps:
1) Updated Buri to v1.4 mozRIL BuildID: 20131211040203
2) Navigate to Marketplace app
3) Install WP Photos app
4) Once installed, tap on Launch button

Actual:
User is taken to "Index of app"

Expected:
WP Photos launches properly

Environmental Variables:
Device: Buri v1.4 mozRIL
BuildID: 20131211040203
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Gecko: 12ea03a70243
Version: 29.0a1
RIL Version: 01.02.00.019.102

Repro frequency: 5/5 100%
See attached: screenshot
Does this reproduce on 1.3, 1.2, or 1.1?
Keywords: qawanted
QA Contact: ckreinbring

Comment 2

5 years ago
This issue also reproduces with Terra and Poppit apps.
Please note, the user is able to launch apps after rebooting device.
I am unable to repro on Buri 1.1, 1.2, or 1.3 mozilla RILs.  Launching the listed apps causes them to load normally every time.

1.3
Build ID: 20140102004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/61f553e5db49
Gaia: 01e9da49be2cc4bc134eeefc434740d572ec2246
Platform Version: 28.0a2
RIL Version: 01.01.00.019.281

1.2
Build ID: 20140102004001
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/0c11156c7d9b
Gaia: b1bc88386c781148a25091bf2eeee3ba217281d0
Platform Version: 26.0
RIL Version: 01.02.00.019.102 

1.1
Build ID: 20140102041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/bdac595a4e46
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Platform Version: 18.1
RIL Version: 01.01.00.019.281
Keywords: qawanted
Were you able to confirm the reproduction on 1.4?
Flags: needinfo?(ckreinbring)
Yes, I was able to repro with all three apps on Buri 1.4 mozilla RIL.

Build ID: 20140102040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/540d85f60c57
Gaia: 67a82f88da231969efa4d22df9fb946abf2cf4df
Platform Version: 29.0a1
Flags: needinfo?(ckreinbring)

Updated

5 years ago
blocking-b2g: --- → 1.4?
Component: General → DOM: Apps
Keywords: regression, regressionwindow-wanted
Product: Firefox OS → Core
Version: unspecified → 29 Branch

Updated

5 years ago
QA Contact: ckreinbring → gbennett

Comment 6

5 years ago
.:First Broken Build:.
Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20131211040203
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Gecko: 12ea03a70243
Version: 29.0a1
Firmware Version: v1.2_20131115

.:Last Working Build:.
Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20131210040206
Gaia: c952e2756c03eceb4de6a3eba15651741a62f9e8
Gecko: df82be9d89a5
Version: 29.0a1
Firmware Version: v1.2_20131115
Keywords: regressionwindow-wanted
(Reporter)

Comment 8

5 years ago
I'm going to change the title of this bug because it applies to multiple apps instead of just WP Photos. Apps that are currently affected by this issue are: Interactive Firefox Logo, Poppit, Terra, and WP Photos.
Summary: [B2G][Marketplace] WP Photos App doesn't load correctly → [B2G][Marketplace] Multiple applications (WP Photos, Poppit, Terra) don't launch correctly upon installing them from the Marketplace

Updated

5 years ago
Duplicate of this bug: 961453

Updated

5 years ago
Duplicate of this bug: 965186
Blocks: 965185

Updated

5 years ago
blocking-b2g: 1.4? → 1.4+
Jason, I'm very sorry, but applying the fix suggested by fabrice for bug 959941 also fixes this one :) !
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 959941

Updated

11 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.