Flash with "Protected Mode" disabled crashes , making Firefox unresponsive, when using the backwards/forwards mouse button with mouse pointer hovering CNN/Youtube video.

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Johan C, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This started a few days ago, on Aurora 27.0a2.

Attempting to navigate back to the previous page freezes Firefox and after a few seconds the unresponsive script warning pops up. The "continue"-button does not work, the "stop plugin"-button returns me to the previous page.

STR (please note that this is difficult to reproduce):
  1. Load a website.
  2. Navigate to a Youtube video.
  3. Let it play for a few seconds, skip ahead to a point which requires further buffering.
  (Note that skipping might not be required)

Comment 1

4 years ago
You should have crash reports in about:crashes. Can you make sure they are submitted and paste some of the crash report IDs?

Do you expect that this is a regression from a Firefox change or a Flash change, or something else?
Flags: needinfo?(johan.charlez)
(Reporter)

Comment 2

4 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> You should have crash reports in about:crashes. Can you make sure they are
> submitted and paste some of the crash report IDs?

https://crash-analysis.mozilla.com/hang-reports/2013/12-11/hr-20131211-962f5db3-4943-4e6f-9c63-b3eef776a52f.html

https://crash-analysis.mozilla.com/hang-reports/2013/12-11/hr-20131211-cb649c9f-edf5-4a45-8df2-0089c8c1a3e8.html

https://crash-analysis.mozilla.com/hang-reports/2013/12-11/hr-20131211-6d6a525e-4a45-4a14-a599-e74104970997.html

https://crash-analysis.mozilla.com/hang-reports/2013/12-11/hr-20131211-3bac53ca-982b-421c-a805-db5990fa662b.html

https://crash-analysis.mozilla.com/hang-reports/2013/12-11/hr-20131211-57286429-f3d7-4dfa-86f5-3b0e8fbed24c.html

> Do you expect that this is a regression from a Firefox change or a Flash
> change, or something else?

I don't remember updating Flash recently, and considering this started 2-4 day ago I can only surmise that this is a Firefox regression.
Flags: needinfo?(johan.charlez)
(In reply to Johan Charlez from comment #2)
> I don't remember updating Flash recently, and considering this started 2-4
> day ago I can only surmise that this is a Firefox regression.

Could you check by trying out on Firefox Beta or Release?
(Reporter)

Comment 4

4 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #3)
> (In reply to Johan Charlez from comment #2)
> > I don't remember updating Flash recently, and considering this started 2-4
> > day ago I can only surmise that this is a Firefox regression.
> 
> Could you check by trying out on Firefox Beta or Release?

Looks like it's also happening (new profile) with:
  ------------------
  Name: Firefox
  Version: 26.0
  User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  ------------------

I'm seeing the issue with HW acceleration enabled on one profile and disabled on another.

Having two tabs with Youtube videos (playing or paused) and switching between the tabs might make it easier to reproduce the issue.

I'm running Flash 11,9,900,170, which according to https://www.mozilla.org/en-US/plugincheck/ is the latest version.

According to the "Program and Features" uninstall tool on Windows "Adobe Flash Player 11 Plugin" was updated on 11/12/2013, but I definitely did not update flash yesterday myself. I will however downgrade and see if the problem persists.
(In reply to Johan Charlez from comment #4)
> According to the "Program and Features" uninstall tool on Windows "Adobe
> Flash Player 11 Plugin" was updated on 11/12/2013, but I definitely did not
> update flash yesterday myself. I will however downgrade and see if the
> problem persists.

Thanks, that would be good to know!
(Reporter)

Comment 6

4 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #5)
> (In reply to Johan Charlez from comment #4)
> > According to the "Program and Features" uninstall tool on Windows "Adobe
> > Flash Player 11 Plugin" was updated on 11/12/2013, but I definitely did not
> > update flash yesterday myself. I will however downgrade and see if the
> > problem persists.
> 
> Thanks, that would be good to know!

The issue persists with:
  11.9.900.117
  11.9.900.152

I know I updated Flash manually a few weeks ago so backtracking any further shouldn't be necessary.
Did you verify that the older Flash version is getting used? You might have ended up still using the newer version.

If it's not a Flash or Fx regression than maybe just a site-change triggered it.
(Reporter)

Comment 8

4 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #7)
> Did you verify that the older Flash version is getting used? You might have
> ended up still using the newer version.
> 
> If it's not a Flash or Fx regression than maybe just a site-change triggered
> it.

I uninstalled Flash before downgrading, and I verified that older versions were being used by right clicking on a flash element. The very last menuitem in the plugin's context menu reads "About Adobe Flash Player 11.9.900.117".
(Reporter)

Comment 9

4 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #7)
> If it's not a Flash or Fx regression than maybe just a site-change triggered
> it.

If a website can cause Firefox to become unresponsive I'd argue that it's a Firefox bug.
Summary: Youtube videos occasionally lock up Firefox when attempting to navigate back to the previous page. → Firefox becomes unresponsive when trying to navigate away from youtube.com, using the "back" or "forward" mouse button while hovering a youtube video.

Comment 10

3 years ago
Hi guys, I tried nightly today and this bug seems fixed. Could anyone else give it a try?

And apparently, since it's still bugged in firefox beta, some work must have been done in the most recent firefox update (I don't know the exact version/build "milestone" though).
(Reporter)

Comment 11

3 years ago
> Hi guys, I tried nightly today and this bug seems fixed. Could anyone else
> give it a try?

This has not been fixed.

Tested on (with extensions disabled):
1. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
2. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
(Reporter)

Comment 12

3 years ago
I have discovered that enabling Flash's "Protected Mode" (set 'ProtectedMode=1' in mms.cfg) breaks support for the backwards and fowards mouse buttons when hovering a CNN or Youtube video. This prevents Flash from crashing and Firefox remains responsive.
Summary: Firefox becomes unresponsive when trying to navigate away from youtube.com, using the "back" or "forward" mouse button while hovering a youtube video. → Flash with "Protected Mode" disabled crashes , making Firefox unresponsive, when using the backwards/forwards mouse button with mouse pointer hovering CNN/Youtube video.
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1066600
(Reporter)

Comment 14

3 years ago
Did some manual regression testing.

Good:
Firefox version 8.0.1 doesn't become unresponsive.

Bad:
Firefox version 9.0 becomes unresponsive for ≈45s. Flash doesn't actually crash, it just hangs the entire browser.

Georg, can anything else be done here?
Flags: needinfo?(georg.fritzsche)
(Reporter)

Comment 15

3 years ago
I couldn't find out if a bug report was filed by the reporter of bug 1066600 so I went ahead and filed https://bugbase.adobe.com/index.cfm?event=bug&id=3917345.
(Reporter)

Comment 16

3 years ago
I can no longer reproduce this, did something land that could have fixed this?
(Reporter)

Comment 17

3 years ago
Cammer, can you still reproduce this?
Flags: needinfo?(cammer)

Comment 18

3 years ago
On what channel? On nightly/aurora we disabled protected mode (bug 1119941).
(Reporter)

Comment 19

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #18)
> On what channel? On nightly/aurora we disabled protected mode (bug 1119941).
Can't reproduce it any longer on beta, aurora or nightly. I haven't tested release though.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

2 years ago
Flags: needinfo?(gfritzsche)
Flags: needinfo?(cammer)
You need to log in before you can comment on or make changes to this bug.