[australis] Paneled expanded menu should use `menuitem` instead of `toolbarbutton`

RESOLVED DUPLICATE of bug 956478

Status

()

RESOLVED DUPLICATE of bug 956478
5 years ago
5 years ago

People

(Reporter: tetsuharu, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

The current Panel's expand menus are implemented with xul `toolbarbutton` element. I seem that xul `menuitem` element are more suitable for this purpose.

Why do we use `toolbarbutton` element?
(Reporter)

Updated

5 years ago
Blocks: 939862

Updated

5 years ago
Blocks: 872617

Comment 1

5 years ago
(In reply to Tetsuharu OHZEKI [UTC+9] from comment #0)
> The current Panel's expand menus are implemented with xul `toolbarbutton`
> element. I seem that xul `menuitem` element are more suitable for this
> purpose.
> 
> Why do we use `toolbarbutton` element?

Because they have special a11y and focus and styling characteristics which aren't suitable for the panel in which they appear?

I'm going to mark this as a duplicate of the more general bug about the different implementations and how they 'should' be working.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 956478
You need to log in before you can comment on or make changes to this bug.