Closed Bug 949286 Opened 6 years ago Closed 6 years ago

Wrong error message when an invalid URL is typed in.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: nhirata, Assigned: aus)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(2 files)

Attached image 2013-12-11-18-25-43.png
Gaia      6415b8b44068596404c10365394544e94edd5ce5
Gecko     http://hg.mozilla.org/mozilla-central/rev/12ea03a70243
BuildID   20131211040203
Version   29.0a1
ro.build.version.incremental=291
Buri

1. setup internet and data connection
2. launch browser
3. go to www.etherpad.mzo

Expected: the URL is invalid/can't find the website
Actual: error w/ no network connection
blocking-b2g: --- → 1.3?
That looks like a regression from the offline error UI rewrite.
Component: Gaia::Browser → Gaia::System::Window Mgmt
Whiteboard: [systemsfe]
Blocks: 882186
Mine! Should have a patch for this today or Monday. :)
Assignee: nobody → aus
Status: NEW → ASSIGNED
Comment on attachment 8349083 [details] [review]
Patch - Handle 'dnsNotFound' as well as 'netOffline' errors in new net_error page.

Commented on github.
Attachment #8349083 - Flags: review?(fabrice) → feedback+
Comment on attachment 8349083 [details] [review]
Patch - Handle 'dnsNotFound' as well as 'netOffline' errors in new net_error page.

Updated the pull request to use the URL object. It's actually cleaner looking. If you don't mind Fabrice, can you give it a quick look before I merge?
(In reply to Ghislain 'Aus' Lacroix from comment #5)
> Comment on attachment 8349083 [details] [review]
> Patch - Handle 'dnsNotFound' as well as 'netOffline' errors in new net_error
> page.
> 
> Updated the pull request to use the URL object. It's actually cleaner
> looking. If you don't mind Fabrice, can you give it a quick look before I
> merge?

I don't think this is ready to merge - see my comments in github.
Attachment #8349083 - Flags: feedback+ → review+
Blocks: 952305
Filed follow-up bug as per github discussion. UX ni? already set.
Fixed on gaia master.

Commit: https://github.com/mozilla-b2g/gaia/commit/6bf24fc3ce7947b70acd2c6f915804f760543fc8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking+ for regression from the error rewrite.
blocking-b2g: 1.3? → 1.3+
This will require uplift to 1.3 branch. Setting flag for it.
I was not able to uplift this bug to v1.3.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.3, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.3
  git cherry-pick -x -m1 6bf24fc3ce7947b70acd2c6f915804f760543fc8
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(aus)
Manually uplifted.

https://github.com/mozilla-b2g/gaia/commit/9a3666854dfa780175458e2bde59c0d645571f09

Marking as such. Thanks :jhford. :)
Flags: needinfo?(aus)
You need to log in before you can comment on or make changes to this bug.