If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[crash] malformed protocol in URL crashes webshell

VERIFIED DUPLICATE of bug 9387

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 9387
19 years ago
19 years ago

People

(Reporter: Chris Waterson, Assigned: Nisheeth Ranjan)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
To reproduce, type "foopy:bazdof" into the URL bar of either viewer or
apprunner.

This happens because NS_NewURL() returns a null URL if it doesn't grok the
protocol (e.g., "foopy:"). Later, when comparing two URLs in EqualBaseURLs()
(nsWebShell.cpp), we attempt to deref the null pointer without checking.

Assigning to rickg b/c I don't know who owns this code. CC'ing warren because
I'm not sure if Necko will do this, also (return a null URL if it doesn't like
the protocol, that is).

Comment 1

19 years ago
In necko, NS_NewURI returns an error. In netlib, NS_NewURL does too. The error
should be checked, not url == nsnull.

Updated

19 years ago
Assignee: rickg → nisheeth

Comment 2

19 years ago
Nisheeth -- please take a look. If it's a webshell bug, whack it -- if not,
let's find the real owner.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 9387 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Agreed. This is a duplicate of 9387.
You need to log in before you can comment on or make changes to this bug.