Travis unit test failure on v1.2: initGridManager is not defined

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: rudyl, Assigned: carmen.jimenezcabezas)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(b2g-v1.2 fixed, b2g-v1.3 unaffected)

Details

Attachments

(1 attachment)

I saw every build on v1.2 failed on this,

--
  1) [homescreen] everything.me.js > Everything.me is displayed > grid.js > onInstall event dispatch before SingleVariant will be ready > Dispatch onInstall before SingleVariant is been ready "before each" hook:
     ReferenceError: initGridManager is not defined
      at (anonymous) (http://homescreen.gaiamobile.org:8080/test/unit/grid_test.js:464)
      at wrapper (http://test-agent.gaiamobile.org:8080/common/test/mocha_generators.js:60)
      at run (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3709)
      at next (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3973)
      at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3984)
      at (anonymous) (http://test-agent.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4932)
Carmen, could it be for something related to single variant? Thanks a lot
Flags: needinfo?(cjc)
(Assignee)

Comment 3

5 years ago
I'll take a look at it
Flags: needinfo?(cjc)
(Assignee)

Updated

5 years ago
Assignee: nobody → cjc
(Assignee)

Comment 4

5 years ago
Created attachment 8347297 [details] [review]
Proposed patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
944495
[User impact] if declined:
none
[Testing completed]:
yes
[Risk to taking this patch] (and alternatives if risky):
very low
[String changes made]:
Fixed unit test on homescreen/grid_test.js
Attachment #8347297 - Flags: review?(crdlc)
Attachment #8347297 - Flags: approval-gaia-v1.2?
Comment on attachment 8347297 [details] [review]
Proposed patch v1

Thanks a lot Carmen. Just a question, could it happen on master and v1.3 as well?
Attachment #8347297 - Flags: review?(crdlc) → review+
(Assignee)

Comment 6

5 years ago
No, this was just a left over from the uplift of bug 925461 to 1.2
(Assignee)

Comment 7

5 years ago
Merged:
https://github.com/mozilla-b2g/gaia/commit/3f2550c2fabea0f16e9c743093c4b61103a8dba8
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g-v1.2: --- → fixed
status-b2g-v1.3: --- → unaffected
Attachment #8347297 - Flags: approval-gaia-v1.2?
You need to log in before you can comment on or make changes to this bug.