Closed Bug 949318 Opened 6 years ago Closed 6 years ago

B2G SMS: Class 2 SMS is not working after ICCRecordHelper.readSMS() was refactored into SimRecordHelper.

Categories

(Firefox OS Graveyard :: RIL, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
1.3 C1/1.4 S1(20dec)

People

(Reporter: bevis, Assigned: bevis)

References

Details

Attachments

(1 file)

The readSMS() method was moved from ICCRecordHelper to SimRecordHelper unexpectedly.
Modification in the caller side is needed accordingly.
A test case will also be needed to cover this.
What's readSMS()?

I never heard this function.
Hi Yoshi,

It's to read the EF_SMS from SIM for support to receive the incoming Class 2 SMS mentioned in bug#943749.
I think the problem is that the patch didn't verify again after including the change in Bug#935401.

Hence, I file this bug to myself to handle this problem and add a new test case to prevent this happen again.
A fix to read SMS with correct API to prevent error in gecko when receiving class 2 SMS.
Test case will be addressed in Bug#792798 instead.
Attachment #8346446 - Flags: review?(vyang)
Attachment #8346446 - Flags: review?(vyang) → review+
https://hg.mozilla.org/mozilla-central/rev/2e160cd10478
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
Duplicate of this bug: 973895
Depends on: 943749
You need to log in before you can comment on or make changes to this bug.