[fugu][buri] network status is not refreshed after fail to join an invalid hidden network on manage network page

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
5 years ago
6 months ago

People

(Reporter: angelc04, Unassigned)

Tracking

unspecified
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

This is reproduced on both V1.2 and V1.3.

STR:
1. Connect to a correct wifi network
2. go to Settings -> WIFI -> Manage networks
3. Tap on "Join a hidden network",input invalid SSID/pwd
4. tap on 'OK'
   WIFI icon disappear from status bar.
   --> But "Known networks" shows previous WIFI network is still connected.
5. Tap on '<' to go back and then go to 'Manage Networks" again. "Known networks" network status is updated.

Test build:
v1.2
Gaia      f615ae7acb6731d191b3094e10e314bc28359bbb                         
Gecko                                                                      
http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/f684b8f159a3         
BuildID   20131209004003                                                   
Version   26.0                                                             
ro.build.version.incremental=eng.archermind.20131114.105818 

v1.3
Gaia      1d45d1dc3201059d5c8f2efdeb92c04576d8e161                         
Gecko     http://hg.mozilla.org/mozilla-central/rev/9f12a9fab080           
BuildID   20131209053402                                                   
Version   28.0a1                                                           
ro.build.version.incremental=eng.archermind.20131114.105818
Duplicate of this bug: 914973

Updated

5 years ago
blocking-b2g: --- → 1.3?
QA,

Please check if this is a regression issue.

Is it also a functional issue v/s UX (as in not displaying the correct name)?
Keywords: qawanted

Comment 3

5 years ago
This issue is reproducing exactly as stated in Comment 0 on the earliest Buri Mozilla 1.2 build I have, so this is not a regression from 1.2.

As for the second question, I'm not exactly sure of what is being asked. After completing Step 4 from Comment 0 the wi-fi connection is actually disconnected after attempting to join an invalid network, though it displays as being connected. After completing step 5, the status is refreshed and the network is not shown as being connected.

Environmental Variables:
Device: Buri v1.2 Mozilla RIL
BuildID: 20130621031231
Gaia: e2f19420fa6a26c4287588701efaec09a750dba1
Gecko: 7ba8c86f1a56
Version: 24.0a1
Base Image: V1.2-device.cfg
Keywords: qawanted
Triage discussed that this is not blocking for 1.3.
blocking-b2g: 1.3? → backlog
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog

Comment 5

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.