Closed Bug 949358 Opened 6 years ago Closed 6 years ago

System app should ensure dialer app is always displayed in portrait mode

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, minor)

Other
Gonk (Firefox OS)
defect
Not set
minor

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: angelc04, Assigned: alive)

References

Details

(Keywords: regression)

Attachments

(3 files)

This is reproduced on both v1.2 and v1.3.

STR:
1. Launc browser and browse some website
2. Rotate to landscape mode
3. Lock screen and keep phone in landscape mode
4. Make a phone call to test device
   --> The incomming call shows in landscape mode
5. Answer the phone
   --> You can see call duration overlapped with menu bar.
Please see attached screenshot.
blocking-b2g: --- → 1.3?
This is not a dialer app issue. The dialer app is only available in portrait mode. So the system app needs to display it in portrait.
Component: Gaia::Dialer → Gaia::System::Window Mgmt
Alive,

Please review and see if you concur that its a system app/ window issue
Flags: needinfo?(alive)
Yes.
Assignee: nobody → alive
Flags: needinfo?(alive)
Summary: [fugu][buri][dialer] call duration overlap with menu bar in landscape mode → System app should ensure dialer app is always displayed in portrait mode
Is this a regression?
Keywords: qawanted
QA Contact: sparsons
This is a regression from 1.1, since this issue started to occur in 1.2.

I was able to repro on the latest 1.2 Build ID: 20140121004053

Gaia   539a25e1887b902b8b25038c547048e691bd97f6
SourceStamp c9f305c1d9a7
BuildID 20140121004053
Version 26.0
Keywords: qawantedregression
So this doesn't reproduce on 1.1?
Flags: needinfo?(sparsons)
Nope, this does not repro on 1.1

(In reply to Jason Smith [:jsmith] from comment #6)
> So this doesn't reproduce on 1.1?
Flags: needinfo?(sparsons)
A dup, Alive?
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(alive)
I heard this issue from Rex before, maybe he knows the dupe source.
Flags: needinfo?(alive)
Flags: needinfo?(rexboy)
What I saw was just this bug. Not sure if other dup exists but I didn't see any for now.
Flags: needinfo?(rexboy)
This issue started to occur on the Buri 1.2 Build ID: 20130926004001

Gaia   1e9470b9b6df630eddf1c4c8b25b3170ee786b0e
SourceStamp caa6b17647c5
BuildID 20130926004001
Version 26.0a2

Last working Buri 1.2 Build ID: 20130925004005

Gaia   b0e4a1333bb7bf0a749a384ba99e4f03f111e39a
SourceStamp fb764e648a8f
BuildID 20130925004005
Version 26.0a2
 
Note: The user cannot answer an incoming call from in landscape view from the first Buri 1.2 (6/21) to the Buri 1.2 (9/25) So, starting on the 1.2 9/26 build is when this issue starts to occur.
Have a patch but I found is unlock + lock is too near, the lock call would return false(fails).
:/
* Fix sleepmenu to avoid redundant sleepmenuhide event to trigger orientation reset.
* Fix orientation manager to avoid reseting while lockscreen is locked.
* Quick fix attention screen to request lock again if the first lock is failing.
Attachment #8366447 - Flags: review?(timdream)
Attached file v1.3 patch
v1.3
Attachment #8366449 - Flags: review?(timdream)
Attachment #8366449 - Flags: review?(timdream)
After experiment, lock orientation succeed in 6th retry, interval = 20ms.
Attachment #8366449 - Flags: review?(timdream) → review+
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #19)
> Comment on attachment 8366447 [details]
> https://github.com/mozilla-b2g/gaia/pull/15718/files
> 
> r+ if you have manually test it.

Yes, result is comment 8.
You need to log in before you can comment on or make changes to this bug.