Closed Bug 949398 Opened 6 years ago Closed 6 years ago

B2G: failed to run marionette-webapi tests on emulator, cannot import name MarionetteTestOptions

Categories

(Testing :: Marionette, defect)

x86_64
Linux
defect
Not set

Tracking

(b2g-v1.3 fixed)

RESOLVED FIXED
mozilla29
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: vicamo, Assigned: vicamo)

References

Details

Attachments

(2 files)

Attached file err.log
When running marionette-webapi tests on B2G emulator-jb locally, it fails with console messages as attached.
Besides, I have to install 'python-py' first on Debian Sid, or an error "no module named py.xml" is returned before "cannot import name MarionetteTestOptions".
I've seen this before, but it usually meant that I have broken modifications to Marionette in my local tree.

What I also see are frequent ScriptTimeoutExcection messages from Marionette, similar to bug 898074.
I saw this on 'emulator' in addition to 'emulator-jb' with 
gecko: github, mozillaorg/master, 2426e60da7c4ac320d67e5c3234e366e503c0cf5 (Dec. 11)
gaia: master, 2426e60da7c4ac320d67e5c3234e366e503c0cf5 (Dec. 11)
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #4)
> I saw this on 'emulator' in addition to 'emulator-jb' with 
> gecko: github, mozillaorg/master, 2426e60da7c4ac320d67e5c3234e366e503c0cf5
> (Dec. 11)
> gaia: master, 2426e60da7c4ac320d67e5c3234e366e503c0cf5 (Dec. 11)

If I rolled back to gecko 42ceb02f64d5275a1f311861a78e7ceee4828a38, then emulator works again.
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #3)
> I've seen this before, but it usually meant that I have broken modifications
> to Marionette in my local tree.

No, that's reproduced on a clean tree.
s/MarionetteTestOptions/BaseMarionetteOptions/ in testing/marionette/mach_commands.py fix the problem.  @jgriffin, is this an acceptable solution?
Flags: needinfo?(jgriffin)
Depends on: 925398
Attached patch patchSplinter Review
Works locally, full try: https://tbpl.mozilla.org/?tree=Try&rev=d2bf9e97c27a
Assignee: nobody → vyang
Attachment #8347237 - Flags: review?(jgriffin)
Flags: needinfo?(jgriffin)
Comment on attachment 8347237 [details] [diff] [review]
patch

Review of attachment 8347237 [details] [diff] [review]:
-----------------------------------------------------------------

I think jgriffin will be back from pto today, but if you'd like to pass the r? to me, I'll r+ it. This is the fix you need since MarionetteTestOptions has been replaced by BaseMarionetteOptions in the newest client.
Comment on attachment 8347237 [details] [diff] [review]
patch

Review of attachment 8347237 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks...I wish we had unit tests for mach commands.  :)
Attachment #8347237 - Flags: review?(jgriffin) → review+
(In reply to Malini Das [:mdas] from comment #9)
(In reply to Jonathan Griffin (:jgriffin) from comment #10)

Thank you :)

https://hg.mozilla.org/integration/b2g-inbound/rev/b2534d128e42
Summary: B2G: failed to run marionette-webapi tests on emulator-jb, cannot import name MarionetteTestOptions → B2G: failed to run marionette-webapi tests on emulator, cannot import name MarionetteTestOptions
(In reply to Jonathan Griffin (:jgriffin) from comment #10)
> I wish we had unit tests for mach commands.  :)

But how did bug 925398 passes all the existing B2G try cases at the very beginning? Does that mean we have another method/script for try-servers? That also the question I had for bug 898074.
It means that mach and TBPL don't run tests using the same way.  Eventually, we'd like TBPL to use mach (or something similar, but vice versa), but this is going to be a bit complicated and isn't at the top of anyone's priority queue.

In the meantime, we should consider adding some basic mach sanity checks to TBPL, I think.
https://hg.mozilla.org/mozilla-central/rev/b2534d128e42
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
You need to log in before you can comment on or make changes to this bug.