If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wifi hotspot does not work if the phone has no SIM card

RESOLVED WONTFIX

Status

Firefox OS
Wifi
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: nbp, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18 affected, b2g-v1.2 affected, b2g-v1.3 affected)

Details

(Reporter)

Description

4 years ago
E/hostapd ( 2935): Configuration file: /data/misc/wifi/hostapd.conf
I/hostapd ( 2935): rfkill: Cannot open RFKILL control device
E/hostapd ( 2935): Failed to update rate sets in kernel module
E/hostapd ( 2935): Using interface wlan0 with hwaddr 48:28:2f:f9:c8:ff and ssid 'nbp2'
I/hostapd ( 2935): random: Only 9/20 bytes of strong random data available from /dev/random
I/hostapd ( 2935): random: Allow operation to proceed based on internal entropy
D/TetherController(  115): addV6RtrAdvIface: len = 1. Iface: wlan0
D/TetherController(  115): Router advertisement daemon stopped
D/TetherController(  115): Router advertisement daemon running
D/TetherController(  115): Setting IP forward enable = 1
D/TetherController(  115): config_write_setting(/proc/sys/net/ipv6/conf/all/proxy_ndp, 2)
D/TetherController(  115): config_write_setting(/proc/sys/net/ipv6/conf/all/forwarding, 2)
D/TetherController(  115): Starting tethering services
D/TetherController(  115): Tethering services running
D/TetherController(  115): setDnsForwarders(0 = '8.8.8.8')
D/TetherController(  115): setDnsForwarders(1 = '8.8.4.4')
D/TetherController(  115): Sending update msg to dnsmasq [update_dns:8.8.8.8:8.8.4.4]
D/radish  ( 2936): Interfaces found: 
D/radish  ( 2936): wlan0
E/radish  ( 2936): Need at least 2 interfaces
I/dnsmasq ( 2937): started, version 2.51 cachesize 150
I/dnsmasq ( 2937): compile time options: no-IPv6 GNU-getopt no-DBus no-I18N DHCP no-scripts no-TFTP
W/dnsmasq ( 2937): warning: no upstream servers configured
I/dnsmasq ( 2937): DHCP, IP range 192.168.0.10 -- 192.168.0.30, lease time 1h
I/dnsmasq ( 2937): DHCP, IP range 192.168.1.10 -- 192.168.1.30, lease time 1h
I/dnsmasq ( 2937): read /etc/hosts - 1 addresses
I/dnsmasq ( 2937): using nameserver 8.8.4.4#53
I/dnsmasq ( 2937): using nameserver 8.8.8.8#53
D/TetherController(  115): Setting IP forward enable = 0
D/TetherController(  115): config_write_setting(/proc/sys/net/ipv6/conf/all/proxy_ndp, 0)
D/TetherController(  115): config_write_setting(/proc/sys/net/ipv6/conf/all/forwarding, 0)
D/TetherController(  115): Stopping tethering services
I/dnsmasq ( 2937): exiting on receipt of SIGTERM
D/TetherController(  115): Tethering services stopped

This feature is working fine on an
  Unagi
    1.3.0.0-prerelease
    27.0a1
    2013-10-17-04
    unagi/1.3.0/default
    <no git commit info>

and it does not work on an
  Unagi
    1.3.0.0-prerelease
    28.0a1
    2013-11-27-10
    default
    2013-11-20 10:09:26 d2b07c09

Note that none of the phones have a sim card, and the USB tethering can be enabled on the latest.

The use case is to create a local network with no internet connectivity which I use to make multiple computer/phones interact on the same network.
QA Wanted - can we see if this reproduces on 1.2?
Keywords: qawanted
I think it's because there's a rule in gaia limits "wifi hotspot cannot be enabled without sim"
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/internet_sharing.js#L106

There's always discussion about should hotspot can be enabled or not without cellular data connection.
The current behavior is based on partner's request, from bug 868902.

So if we allow enable hotspot without cellular data, there will be another bug says we shouldn't.
I like to have someone, but don't know who, to make a final call, and settle down the issue once forever.
Component: Wifi → Gaia::System

Updated

4 years ago
QA Contact: gbennett

Comment 3

4 years ago
This does not repro on 1.2. Both devices used do not have SIM cards and no Wi-Fi hotspot can be found.

Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131213004002
Gaia: 1aca7c4860e39b1a9969807d335dcf9f070ea9b3
Gecko: a2b69b561d9b
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: 20131115
Keywords: qawanted

Comment 4

4 years ago
(In reply to gbennett from comment #3)
> This does not repro on 1.2. Both devices used do not have SIM cards and no
> Wi-Fi hotspot can be found.
> 
> Environmental Variables:
> Device: Buri 1.2 comRIL
> BuildID: 20131213004002
> Gaia: 1aca7c4860e39b1a9969807d335dcf9f070ea9b3
> Gecko: a2b69b561d9b
> Version: 26.0
> RIL Version: 01.02.00.019.102
> Firmware Version: 20131115

"This does repro"
status-b2g-v1.2: ? → affected
Does this reproduce on 1.1?
Keywords: qawanted

Comment 6

4 years ago
This repros on 1.1, but not in the same way as 1.2. 1.2 the wifi hotspot does not show up when searching for a wifi connection. 1.1 other devices can see and connect to the wifi hotspot, but are unable to surf the web or use the connection for online purposes.

Environmental Variables:
Device: Buri 1.1 mozRIL
BuildID: 20131210041202
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Gecko: 05117f42088f
Version: 18.0
RIL Version: 01.02.00.019.102
Firmware Version: 20131115

Updated

4 years ago
status-b2g18: --- → affected
Keywords: qawanted
(Reporter)

Comment 7

4 years ago
(In reply to gbennett from comment #6)
> This repros on 1.1, but not in the same way as 1.2. 1.2 the wifi hotspot
> does not show up when searching for a wifi connection. 1.1 other devices can
> see and connect to the wifi hotspot, but are unable to surf the web or use
> the connection for online purposes.

You mean this cannot be reproduced on 1.1? This is expected that you cannot browse the Web if you do not have any Sim card on the phone which is hosting the Wifi Hotspot, and unless you mean that the phone which connects to the wifi hotspot cannot browse the web even if it has a sim card? In which case this another issue.

Comment 8

4 years ago
(In reply to Nicolas B. Pierron [:nbp] from comment #7)
> You mean this cannot be reproduced on 1.1? This is expected that you cannot
> browse the Web if you do not have any Sim card on the phone which is hosting
> the Wifi Hotspot, and unless you mean that the phone which connects to the
> wifi hotspot cannot browse the web even if it has a sim card? In which case
> this another issue.

Ah if that is the expected then everything is working fine for 1.1 as I did not have a SIM card in the phone, sorry for any confusion.
I think this would be classified under WiFi, but feel free to re-categorize if I'm wrong.
Component: Gaia::System → Wifi
Per comment 2, I think this bug should be marked as invalid because it is by design.
Duplicate of this bug: 956859
Blocks: 942267
Hi michael can you please suggest for #comments 2 (https://bugzilla.mozilla.org/show_bug.cgi?id=949408#c2)
Flags: needinfo?(mvines)
comment 2
Whiteboard: [CR 591200]
Whiteboard: [CR 591200] → [CR 585964]
Seems like the behavior should be customizable by a preference, as I don't think there's uniform agreement on this across OSes and operators.   But as the current behavior is WAD, adding such a preference or flipping the default is not blocking for us.
No longer blocks: 942267
Flags: needinfo?(mvines)
(In reply to Michael Vines [:m1] [:evilmachines] from comment #14)
> Seems like the behavior should be customizable by a preference, as I don't
> think there's uniform agreement on this across OSes and operators.   But as
> the current behavior is WAD, adding such a preference or flipping the
> default is not blocking for us.

Not a blocker per this above comment.
blocking-b2g: 1.3? → -
Whiteboard: [CR 585964]

Comment 16

3 years ago
According comment 2, 10, and 14, It is by design and not a real issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: regression
Resolution: --- → WONTFIX
I am confused with the output of this issue. I understand that this feature is not a blocker for a given release, but I don't understand if we're planning to have it one day or not.
Flags: needinfo?(mvines)
I don't understand why you are marking this bug as wontfix - what about the case where I do have a sim card ? does the wifi hotspot works in this case ?
Flags: needinfo?(kchang)

Comment 19

3 years ago
(In reply to Tarek Ziadé (:tarek) from comment #18)
> I don't understand why you are marking this bug as wontfix - what about the
> case where I do have a sim card ? does the wifi hotspot works in this case ?
Why you need this? May you please provide a user scenario?
We can base on your scenario to think if we need to add this feature in firefox os.
But now this bug is different from current design of firefox OS. That is why I mark it wontfix.
Flags: needinfo?(kchang)
> Why you need this?

to create a wifi hotspot ?

> May you please provide a user scenario?

User creates a wifi hotspot...

One question you have not answered, is if it will work with a sim card ? does the wifi hotspot still works in this case ?

> We can base on your scenario to think if we need to add this feature in firefox os.
But now this bug is different from current design of firefox OS. That is why I mark it wontfix.

I don't understand these two sentences. If it's decided that the wifi hotspot won't work when the phone
does not have a sim card - that's fine and that was explained.

I would just like to know if this feature will be present when we do have a sim card. If not there is probably a good reason and I'd love to know what is that reason. Please don't answer with more questions ;)
Flags: needinfo?(kchang)

Comment 21

3 years ago
Comment 2 has answered your question...:-)
Flags: needinfo?(kchang)
No it's not as far as I see. Please answer to this question by yes or no:

will wifi hotspot be supported on a phone that contains a sim card ?
Flags: needinfo?(kchang)
(Reporter)

Comment 23

3 years ago
(In reply to Tarek Ziadé (:tarek) from comment #22)
> No it's not as far as I see. Please answer to this question by yes or no:
> 
> will wifi hotspot be supported on a phone that contains a sim card ?

After testing on a recent build, it seems to be working if there is a sim card in the phone which serve as hotspot.  I don't know if phones connected on one device can communicate between each others, as it was before, or if this is only used for tunneling.
Thanks for the testing Nicolas
Flags: needinfo?(mvines)
Flags: needinfo?(kchang)

Updated

3 years ago
Summary: Wifi hotspot does not work. → Wifi hotspot does not work if the phone has no SIM card
You need to log in before you can comment on or make changes to this bug.