Closed Bug 949411 Opened 6 years ago Closed 6 years ago

[Download Manager] The download list is emptied after closing the settings app

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

Other
Other
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

VERIFIED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: rafael.marquez, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

*Procedure
1. Download some files
2. Open the download list and verify that tue files are displayed
3. Close settings app if it is opens. You can verify and closed it from task switcher
4. Reopen download list after closing settings app

*Expected Result
Are download files are displayed in download list after closing and reopening settings app

*Actual Result
The download list is emptied after closing the settings app
blocking-b2g: --- → 1.4?
Whiteboard: [systemsfe]
Hola Rafa, I've just tested this bug but it is not reproducible anymore with latest builds (I thought that the problem was the datastore but I don't pretty sure). Could you confirm it? Maybe I am wrong but it is working fine for me right now. Thanks a lot
Keywords: qawanted
Issue still occurs on latest Buri 1.4 build, the files are not shown after ending the setting app. Possibly blocked by bug 949402 due to the fact that you need to have settings open already to see the downloaded files listed in the downloads section or the files will not be shown.

Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140102040201
Gaia: 67a82f88da231969efa4d22df9fb946abf2cf4df
Gecko: 540d85f60c57
Version: 29.0a1
RIL Version: 01.02.00.019.102
Firmware Version: v1.2_20131113
Keywords: qawanted
Issue still occurs on latest unagi master build
Hi Andrea,

   I've tested the issue and it is related to datastore.get when the parameter is a sequence of ids. It was working fine in the past but right now is not working. Is there any bug or change in the Datastore API?

   Promise get(unsigned long id) -> OK
 
   Promise get(sequence<unsigned long> id) -> Nothing is returned

Thanks in advance
Flags: needinfo?(amarchesini)
Hi Cristian,

yes, DataStore API is slightly changed. Now the get is this:

   Promise get(DataStoreKey... id);

and DataStoreKey is:

 typedef (DOMString or unsigned long) DataStoreKey;

Wiki page is now up-to-date: https://wiki.mozilla.org/WebAPI/DataStore

For you problem you should do this:

  dStore.get(1, 2, 3, 4).then(...

or if you have:

  ids = [1, 2, 3, 4]
  dStore.get.apply(dStore, ids).then(...
Flags: needinfo?(amarchesini)
It works like a charm, thanks a lot
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attachment #8359240 - Flags: review?(francisco.jordano)
Duplicate of this bug: 956346
Attachment #8359240 - Flags: review?(francisco.jordano) → review+
Merged in master:

https://github.com/crdlc/gaia/commit/0019510fce80aa9575e24a59455982ca781845d2
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
the bug is not solved with this patch. I have opened a new bug (bug 960476) for this issue.
Depends on: 960476
Status: RESOLVED → VERIFIED
blocking-b2g: 1.4? → 1.4+
You need to log in before you can comment on or make changes to this bug.