[B2G][FTE]"Cellular Data" menu is shown during FTE without SIM card inserted

RESOLVED DUPLICATE of bug 926347

Status

RESOLVED DUPLICATE of bug 926347
5 years ago
5 years ago

People

(Reporter: rkunkel, Assigned: mikehenrty)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(1 obsolete attachment)

(Reporter)

Description

5 years ago
Description:
If a user goes through the FTE process without a SIM card inserted, they are brought to the "Cellular Data" menu and can toggle 'Enable Data'.

Repro Steps:
1) Update Buri to v1.3 BuildID: 20131210004003
2) Remove SIM Card
3) Perform FTE, Settings > Device information > More Information > Reset Phone.
4) After selecting a language and hitting Next the user accesses the "Cellular Data" menu and can toggle 'Enable Data' without a sim card.

Actual:
Without a sim card, "Cellular Data" menu is shown during FTE and users can toggle 'Enable Data'.

Expected:
"Cellular Data" menu is skipped.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20131210004003
Gaia: 3452fbdb5e1bed0cd27cc6173136537a03e8072f
Gecko: e0c328d99742
Version: 28.0a2
Firmware Version: V1.2_US_20131115

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/5134/
(Reporter)

Comment 1

5 years ago
This does not reproduce in latest 1.2 Buri build.

Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131211004007
Gaia: 096722a9e2510ecdfe45ba7382d7d50826b82feb
Gecko: 43d7b300241a
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: V1.2_US_20131115
Keywords: regressionwindow-wanted
(Reporter)

Updated

5 years ago
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → affected
Keywords: regression
My best guess is commit https://github.com/mozilla-b2g/gaia/commit/11ba835d2a794b2fe9846b22fc898bc35d9847c3 but I need to test it
Created attachment 8347199 [details] [review]
Link to PR -  https://github.com/mozilla-b2g/gaia/pull/14649
Attachment #8347199 - Flags: review?(felash)
Attachment #8347199 - Flags: feedback?(borja.bugzilla)
Comment on attachment 8347199 [details] [review]
Link to PR -  https://github.com/mozilla-b2g/gaia/pull/14649

And this is what happens qhen you have too many bugs open at the same time -.-
Attachment #8347199 - Attachment is obsolete: true
Attachment #8347199 - Flags: review?(felash)
Attachment #8347199 - Flags: feedback?(borja.bugzilla)

Updated

5 years ago
blocking-b2g: --- → 1.3?

Updated

5 years ago
Keywords: regressionwindow-wanted

Updated

5 years ago
Keywords: regressionwindow-wanted
(Reporter)

Updated

5 years ago
QA Contact: rkunkel
(Reporter)

Comment 5

5 years ago
Regression Window

- Last Working -

12/04
Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20131204115608
Gaia: 324c467fc6b202fd09efe4b16cd83960fd2901eb
Gecko: 526e12792fc8
Version: 28.0a1
Firmware Version: V1.2_US_20131115

- First Broken - 

12/05
Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20131205040201
Gaia: 1dd0e5c644b4c677a4e8fa02e50d52136db489d9
Gecko: 725c36b5de1a
Version: 28.0a1
Firmware Version: V1.2_US_20131115
Keywords: regressionwindow-wanted
From Gaia range, could be bug 942908.
Flags: needinfo?(mhenretty)

Updated

5 years ago
Whiteboard: [systemsfe]
Yup, this is my fault. I put some temporary code as a stop gap for adding dual sim support, and it broke the non-sim fte flow: 

https://github.com/mozilla-b2g/gaia/commit/11ba835d2a794b2fe9846b22fc898bc35d9847c3#diff-e21eaf0faf7b9695ef0f3f72f344075cR123

In any case, this will be fixed by bug 926347, which I plan on landing shortly. So I will take this bug and verify it's fixed once that one lands.
Assignee: nobody → mhenretty
Flags: needinfo?(mhenretty)
Blocks: 942908
Depends on: 926347
Just verified on the latest nightly that "Cellular Data" screen is skipped in FTU when no SIM is inserted.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
That's a wfm then, as there's no patch here.
blocking-b2g: 1.3? → ---
Resolution: FIXED → WORKSFORME
Best would be to find which patch fixed this ;)
(In reply to Julien Wajsberg [:julienw] from comment #10)
> Best would be to find which patch fixed this ;)

It's this patch: https://github.com/mozilla-b2g/gaia/commit/e2c232208f0177d7a9305a60a6c59e62d98a67a2

If we know the patch, do we still resolve with WFM?
Nope, we mark as dupe :) Thanks Michael!
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 926347
You need to log in before you can comment on or make changes to this bug.