When i type-in/D&D/paste a URL into mozilla, it opens a different URL

VERIFIED DUPLICATE of bug 38488

Status

()

Core
Networking: HTTP
--
major
VERIFIED DUPLICATE of bug 38488
17 years ago
17 years ago

People

(Reporter: orionbelt, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803
BuildID:    20010803

This is a rather spooky one...

I've been using mozilla rather regularly since 0.8 but this only appeared in
0.9.3. I am using RH 7.1 and KDE. I spent some time looking into the bug list
but could not find any related bug report, even though if this happens as often
as in my case, it should be a fairly common and severe bug report! I got the
mozilla i am using following the links on the mozilla site:

% rpm -qi mozilla-0.9.3-0
Name        : mozilla                      Relocations: /usr
Version     : 0.9.3                             Vendor: Red Hat, Inc.
Release     : 0                             Build Date: Fri 03 Aug 2001 08:56:40
PM EEST
Install date: Wed 08 Aug 2001 12:48:04 AM EEST      Build Host:
stripples.devel.redhat.com
Group       : Applications/Internet         Source RPM: mozilla-0.9.3-0.src.rpm
Size        : 17438979                         License: MPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>

First time i saw it while using the bookmark manager. I would drag & drop a URL
into a mozilla browser window. The URL line would sometimes change to the new
URL (as it should) but sometimes it would append the new URL (including the
"http://" string) at the end of whatever there was already in the URL line.

Either way, the browser would not display the new URL, but it would reload the
old URL (i.e., whatever the was in the URL line prior to the drag & drop operation).

Hitting reload, holding down the shift key, or retyping the URL from scratch did
not help. So this must not be related with the bookmark manager, but should be a
browser problem.

Ever since, i noticed the problem in a number of different occasions. I cannot
say i noticed any regularity as to when or how it occurs, except this: it seems
to happen mainly when the target URL involves some sort of redirection.


Reproducible: Sometimes
Steps to Reproduce:
I am not sure this will work for you, or even for me (because it may depend on
what happened before the following steps actually take place).

1. Open Bookmark Manager, where among other URLs i have this: http://www.go-rts.com/

2. Drag & drop this URL into the mozilla browser window.

3. It may help if, before doing this, you drag & drop other URLs from your
Bookmark list. Give it some time and try several different URLs, until the
problem arises.

4. Note: If this bug has to do with redirection alone, it may suffice to just
try to open the URL without messing with the bookmark manager. In fact, this is
what happens to me, but i mention the bookmark procedure because it may have to
do with how it started.


Actual Results:  It takes me to a Web mail page from BellSouth company! Note:
chances are good that http://www.go-rts.com is actualy hosted on BellSouth
servers, so this may well be a redirection problem!

The "Page Info" window (right-click, "View Page Info") thinks it is actually
http://www.go-rts.com that i am viewing, but the "Images" tab correctly
identifies the displayed image as
http://images.bellsouth.bigfoot.com/images/bellgreen/your_neighbor.com.gif
(see also Additional Info below)



Expected Results:  Netscape 4.77 correctly takes me to the city of Gainesville
Regional Transit System.

Here is the source of the BellSouth page that is actually downloaded:

<!-- saved from url=(0022)http://internet.e-mail -->
<html>
<head><title>WebEmail Alert</title>
</head>
<body
BACKGROUND="http://images.bellsouth.bigfoot.com/images/bellgreen/main_back.gif"
BGCOLOR="#FFFFFF" TEXT="#000000" LINK="#005EAD" VLINK="#32748D" ALINK="#0000EE">

<table cellspacing=0 cellpadding=0 border=0 width=600>
<tr> <td align="center" valign="TOP"><a href="http://www.bellsouth.com"><img
src="http://images.bellsouth.bigfoot.com/images/bellgreen/your_neighbor.com.gif"
alt="click here to go to the home page" width=600 height=55 border=0></a>
<br><br>
<font face=arial,helvetica,sans-serif size=2>
The WebEmail system will be down from 12:00 am until 6:00 am
<br>Saturday morning for system maintenance and upgrade.
<br>
Thank you for your patience.</font>
</td>
</tr>
</table>

</body>
</html>
Reporter:
Are you using a proxy (junkbuster) ?
(Reporter)

Comment 2

17 years ago
Yes, i am using junkbuster.

However, Netscape was also using junkbuster, and yet it displayed the correct URL.
Anyway, i have disabled junkbuster on mozilla to see if it helps. It would be
rather bad if i could not use junkbuster any more, though...
junkbuster itself is broken...
You can use junkbuster if you change the http version from 1.1 to 1.0 under 
edit\preferences\debug\networking

Other Browser works fine with junkbuster because:
NS4.7x use only Http 1.0
IE5.x use http1.0 for all proxies
Please read bug 38488 for all informations..

*** This bug has been marked as a duplicate of 38488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
QA Contact: tever → bbaetz
Resolution: --- → DUPLICATE
VERIFIED
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
Does the problem go away if you turn off junkbuster?
Subject: Re: [Bug 94966] When i type-in/D&D/paste a URL into mozilla, it opens a 
different URL
Date: Mon, 13 Aug 2001 00:01:33 +0300 (EEST)
From: "Christos Siopis <siopis@astro.ufl.edu>" <siopis@astro.ufl.edu>
To:<Matti@epost.de>
CC:Christos Siopis <siopis@astro.ufl.edu>

Good job Matti, thanx for the quick reply and resolution!

I guess i should now wait till the Junkbuster gets up to date... Though i
am not sure what the advantages of HTTP 1.1 are, nor if they are used at
all by web site developers...

You need to log in before you can comment on or make changes to this bug.