crash in mozilla::ipc::UnixSocketImpl::OnFileCanWriteWithoutBlocking(int)

RESOLVED WORKSFORME

Status

Firefox OS
Bluetooth
--
critical
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Salem Elkabule, Unassigned)

Tracking

({crash, regression, reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun1.3-1 , crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-e737636a-bce1-43f8-9ed9-f3a902131212.
=============================================================

Video: http://youtu.be/nQ_xF_CJWpw

Repro Steps:
1) Updated Buri v1.3 build ID: 20131211004003
2) Start the transfer for 3 files via Bluetooth between the 2 devices
3) On the first file transfer select "Cancel"
4) On the second transfer "Accept" and complete the transfer
5) When transferring the third file, Select "accept" to receive the file on the testing device
6) Turn off "Bluetooth" in the middle of the transfer

Actual:
The testing device crashes

Expected:
The transfer notification indicates that there was an error while transferring the file 

Environmental Variables
Device: buri v 1.3.0 Mozilla RIL
Build ID: 20131211004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/6bb84d0bc170
Gaia: 7a2ccae2a546ac4d981d250272dafa630c926422
Platform Version: 28.0a2

Note: Observe the device on the left in the video

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/4094/
Hi,

From the report, this looks like a duplicate of bug 936402. Could you please apply the patch from this bug and try again? Thanks!
QA Wanted for comment 1.
blocking-b2g: --- → 1.3?
Keywords: qawanted, regression, reproducible

Updated

4 years ago
QA Contact: gbennett

Comment 3

4 years ago
I am not able to reproduce on the latest 1.3 which has that patch applied. Per Mila's instructions I'm resolving as WorksForMe.

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131213004002
Gaia: 888f9df5515a47d2f5806efee77485e05e1e5416
Gecko: dfae9c83bfbc
Version: 28.0a2
RIL Version: 01.02.00.019.102
Firmware Version: 20131115
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Keywords: qawanted

Updated

4 years ago
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.