recent picture preview can attempt to display up to 3 images simulaneously

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: tracy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxos-bug-bash-1.2])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8346947 [details]
video of this cycling through 3 selected photos

If you take a few pictures, then quickly select one of the preview images, one after the other. The viewer attempts to display each rapidly in repeated succession.

STR:

1) take several photos.
2) access the recently taken pictures at the top of the camera viewer
3) click 2-3 of the recent photos.

tested results:
the view cycles rapidly through displaying each of the selected images.

expected results:
only one image should be allowed to be selected and shown.

Updated

5 years ago
Whiteboard: [fxos-bug-bash-1.2]

Updated

5 years ago
Component: DOM: Device Interfaces → Gaia::Gallery
Product: Core → Firefox OS
Version: 26 Branch → unspecified
QA Wanted - Does this reproduce on 1.1?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #1)
> QA Wanted - Does this reproduce on 1.1?

Note - you'll need to test this on a Helix device.
According to the video, this is a bug of camera.
Component: Gaia::Gallery → Gaia::Camera
Does not reproduce on a 1.2 Buri device. If I can get the camera working on my Helix I'll see if I can reproduce it there.  I'm responsible for that filmstrip and camera preview code, so if this bug checks out and is reproducible, you can assign it to me.  On the other hand, all that flicker looks like it could be normal crazy unusable Helix graphics to me.
(In reply to David Flanagan [:djf] from comment #4)
> Does not reproduce on a 1.2 Buri device. If I can get the camera working on
> my Helix I'll see if I can reproduce it there.  I'm responsible for that
> filmstrip and camera preview code, so if this bug checks out and is
> reproducible, you can assign it to me.  On the other hand, all that flicker
> looks like it could be normal crazy unusable Helix graphics to me.

During the bug bash, I think we thought this was WVGA-specific, so I think you'll need test this on a Helix device.
I reflashed my helix with 1.2 from pvtbuilds and I cannot reproduce this bug.

If someone can come up with STR that are reliable, please assign it to me.
Leaving QA Wanted then to see if we can reproduce this on 1.2.
I was not really able to repro on Helix 1.1hd commercial RIL.  I did notice that tapping different pictures in rapid succession caused the screen to go blank for a few seconds before the last picture tapped appears on the screen.

Build ID: 20131213042232
Gecko: 94c719e506b1
Gaia: 2d79d8c461262b4d819fba17a0e8cbc03b36b6b1
Platform version: 18.0
RIL Version: 01.01.00.019.281
Keywords: qawanted
QA Contact: ckreinbring
probably going to have close this if we don't have clear str
Whiteboard: [fxos-bug-bash-1.2] → [fxos-bug-bash-1.2][closeme 12/20/2013]
I have been able to repro on Helix 1.2 commercial RIL.  It seems to be a timing issue.  Too fast and the device ignores the middle selected picture(s).  Too slow and the device can show the picture as fast as the user can tap it.

Build ID: 20131213004002
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/a2b69b561d9b
Gaia: 1aca7c4860e39b1a9969807d335dcf9f070ea9b3
Platform Version: 26.0
RIL Version: 01.02.00.019.102
Okay - can you try using the testing you did in comment 10 to see if this happens on 1.1 HD?
Keywords: qawanted
Whiteboard: [fxos-bug-bash-1.2][closeme 12/20/2013] → [fxos-bug-bash-1.2]
Unable to repro on Helix 1.1HD commercial RIL.  Also, even when I was able to repro on 1.2 I didn't see the extreme results that is shown in the video clip.

Build ID: 20140102042202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/7245241c6c8f
Gaia: 2d79d8c461262b4d819fba17a0e8cbc03b36b6b1
Platform Version: 18.1
RIL Version: 01.01.00.019.281
Keywords: qawanted
Can we check if this happens on a 1.3 Helix Moz RIL build?
Keywords: qawanted
I was unable to repro the bug in the same way as the video clip on Helix 1.3 mozilla RIL.  I could sometimes make it attempt to catch up to rapid tapping like in the 1.2 version.  

Build ID: 20140102004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/61f553e5db49
Gaia: 01e9da49be2cc4bc134eeefc434740d572ec2246
Platform Version: 28.0a2
Keywords: qawanted
No longer an issue with new camera app.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.