[UX][SMS][MMS] Show indicate empty conversation

RESOLVED DUPLICATE of bug 996900

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 996900
5 years ago
4 years ago

People

(Reporter: ypwalter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxos-bug-bash-1.2])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
When try to edit a message, he wants to click the center (empty space) for write message instead of the input box down below. 

I think there should be a message showing "empty conversation" or something. So that people can know they should type message in the input box.

Also, maybe it should show "type message here" instead of "message" inside the input box.
(Reporter)

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
(Reporter)

Updated

5 years ago
Whiteboard: [fxos-bug-bash-1.2]
I find these are good proposals!

What do you think Ayman?
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(aymanmaat)
(Reporter)

Comment 2

5 years ago
I also suggest that trying to scan through all the screens in the phone, and you can try to think yourself as a child or a newbie to all the phone. You might be able to figure out there should be some notification on some screen. (not restricted to sms/mms)

Thanks.
That's actually where we need new eyes on the apps: we're working with them for a long time and it's a good thing to have opinions coming from outside.

Comment 4

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #1)
> I find these are good proposals!
> 
> What do you think Ayman?

Yep, thats a very good set of proposals. Its nice to have some fresh eyes on the app making objective proposals about how it can be improved/enhanced. I welcome that.

We dont have the bandwidth to make these alterations now, but we should certainly consider them as we begin the IxD redesign of the messages app (the first sketches of which i am currently doing now).

leaving ni? for me in place as a marker to where these proposals are. Thanks Walter

Comment 5

5 years ago
Good proposal!

I ll take up with these. 

I ll upload the patch soon.

However, indicating the empty conversation should it be by something like toast message as in android?

Because if we display Empty conversation then the user may be confused whether he has received a message which is typed with Empty Conversation.

kindly assign my name as against these issue.
ankit, as you pointed correctly, we first need some UX and Visual Design work so I can't assign you yet.

Ayman, do you think you could give a rough UX behavior so that José can provide a Visual Design? It does not look like a big work (although I know even small work takes time...)

Comment 7

4 years ago
Instead of "message" we can write easily "Type your message".

What more is needed?

Till that its done.
I think we want to do something with the empty space as well.

Comment 9

4 years ago
Suggest some idea about what to do?

Don't you think that polluting much in the SMS app will come complex & would slow down the App??
I added a "needinfo" on Ayman so that he'll suggest what to do ;)

Such a thing won't pollute the SMS app, don't worry.

Comment 11

4 years ago
Created attachment 8357593 [details] [diff] [review]
bug949837.patch

These patch is for "Type your Message" instead of "Message". So the user will fell good.

What changes in UX required?
Attachment #8357593 - Flags: review?(felash)
Attachment #8357593 - Flags: feedback?(felash)
Comment on attachment 8357593 [details] [diff] [review]
bug949837.patch

Review of attachment 8357593 [details] [diff] [review]:
-----------------------------------------------------------------

I still think we need something in the empty space, and for this I need UX and Visual Design.

::: apps/sms/locales/sms.en-US.properties
@@ +34,4 @@
>  send                       = Send
>  new                        = New
>  message                    = Message
> +composeMessage.dataset.placeholder = Type your Message here

You need to change the key when you change the value, this is to ensure that the localizers know about this change and do the change in all languages.
Attachment #8357593 - Flags: review?(felash)
Attachment #8357593 - Flags: review-
Attachment #8357593 - Flags: feedback?(felash)

Comment 13

4 years ago
Any update on UI/UX/Visual design part?

Comment 14

4 years ago
Still awaiting for UX input.
Flags: needinfo?(felash)
In the visual refresh we'll have a clickable white area instead of a unclickable grey area.

Also, in byg 918970 we're trying to implement autoloading a thread when it exists.

So I think we should just land the l10n change here after all.

I'll send a mail to Ayman separately.
Flags: needinfo?(felash)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 996900
Flags: needinfo?(aymanmaat)
You need to log in before you can comment on or make changes to this bug.