[Email] Cannot read Email via 3G network, Ok while switching to Wifi

RESOLVED DUPLICATE of bug 914569

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 914569
4 years ago
4 years ago

People

(Reporter: ericcc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxos-bug-bash-1.2])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8346991 [details]
2013-12-13-10-22-34.png

Description:
Cannot read Email via 3G network,  Ok while switching to Wifi 


Steps to Reproduce:

1. Set up an email account with some email via Wifi
2. Read inbox
3. Turn off Wifi, using 3G network

Expected Results:
* Can read email


Actual Results:
* Bad Password notification shown


Additional Notes:
* Works fine while switching back to Wifi


Environmental Variables:

Version: 1.2
Device: Buri
Build Date: 12/12/2013
RIL Type (Mozilla RIL or Commericial RIL): Commericial RIL
(Reporter)

Comment 1

4 years ago
Created attachment 8346992 [details]
WifiOKAY.png
Attachment #8346991 - Attachment is obsolete: true
(Reporter)

Comment 2

4 years ago
Created attachment 8346993 [details]
3GBadPassword.png
gmail probably thinks the IP address of the 3G network is suspicious and this is us mis-reporting that error as a bad password.  Bug 914569 covers handling the error case better.

Log in to the gmail web interface and tell gmail the IP address is okay.  If there doesn't seem to be an indication there, please generate a logcat where you enter the password in the dialog.  We should log something useful during the checkAccount notification.
Just looked at the wifi-okay png.  That is showing us this is what the problem is.  Duping to bug 914569.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 914569
You need to log in before you can comment on or make changes to this bug.