Object.freeze(<non-empty Typed Array>) throws InternalError

RESOLVED DUPLICATE of bug 1120503

Status

()

defect
RESOLVED DUPLICATE of bug 1120503
6 years ago
4 years ago

People

(Reporter: emk, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
Steps to reproduce:
Object.freeze(new Uint8Array(1));

Actual result:
InternalError: can't set attributes on indexed array properties

Expected result:
Do whatever else throwing InternalError. I don't know the correct behavior from the spec perspective, but it would not be throwing a SpiderMonkey extension.

Chrome (V8) throws TypeError.
IE11 didn't throw, but it had no effect either. (The frozen typed array object was still writable.)
Now throws a type error for non empty arrays, which should be correct per spec.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120503
You need to log in before you can comment on or make changes to this bug.