Closed Bug 949888 Opened 7 years ago Closed 7 years ago

Rooting hazard in Navigator::HasDataStoreSupport

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 940765

People

(Reporter: bzbarsky, Unassigned)

References

Details

(Keywords: regression)

Bug  942639 introduced a rooting hazard: the unrooted aGlobal is used after the preference gets, and we have no guarantee that the preference gets won't GC.

I recommend moving this line:

  nsCOMPtr<nsPIDOMWindow> win = GetWindowFromGlobal(aGlobal);

to before the preference gets.
I guess bug 940765 fixes this too.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940765
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.