Closed Bug 950074 Opened 6 years ago Closed 6 years ago

[Messages] The "you received a message" notice has a bad layout

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: julienw, Assigned: julienw)

References

Details

Attachments

(2 files)

Attached image 2013-12-13-17-01-39.png
STR:
* have 2 devices A and B
* from device A, open the thread for the phone number of device B. This thread must have a scroll bar
* scroll it up
* with the phone B, send a sms to phone A

=> a notice containing the text "New message from <phone number>" with a "read it" button is displayed.

However the "read it" button is displayed to low (see screenshot). It should be besides the text (see https://bug905208.bugzilla.mozilla.org/attachment.cgi?id=810514 for the expected layout).

Adding "regression wanted" and ask for 1.3.
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
I'd bet on a change in the building blocks.
QA Contact: sarsenyev
There is no regression window for this issue.
The bug reproduces from the first build when the future was implemented aka 10/15/2013 on master build 1.3
"Read it" is placed lower than "New message"

Device: Buri 1.3 Central build
BuildID: 20131015040202
Gaia: 17e871ae1f82699793e3cd28acda805ba724a8b6
Gecko: febfe3c7732b
Version: 27.0a1
Firmware Version: v1.2_20131115
Assignee: nobody → felash
Keywords: regression
Blocks: 905208
Attached patch patch v1Splinter Review
The github PR is https://github.com/mozilla-b2g/gaia/pull/14669

For some reason the commited CSS was wrong.
Converted it to flex box so that it looks correct also on bigger screens (like
the Peak).
---
 apps/sms/style/sms.css | 19 +++++++++++--------
 1 file changed, 11 insertions(+), 8 deletions(-)
Attachment #8347438 - Flags: review?(schung)
To triagers: so, it's not a regression, the landed feature was not correct.
Comment on attachment 8347438 [details] [diff] [review]
patch v1

Review of attachment 8347438 [details] [diff] [review]:
-----------------------------------------------------------------

I left some comment in https://github.com/mozilla-b2g/gaia/pull/14669, since these concerns are not blocking and not quite related to the issue, r=me and comments are nice to have. Thanks.
Attachment #8347438 - Flags: review?(schung) → review+
Comment on attachment 8347438 [details] [diff] [review]
patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 905208
[User impact] if declined: bad layout (see attachment)
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): safe, only CSS in a fairly contained location
[String changes made]: none
Attachment #8347438 - Flags: approval-gaia-v1.3?(fabrice)
Comment on attachment 8347438 [details] [diff] [review]
patch v1

Sorry, will provide a slightly bigger patch, so will ask approval on the new patch instead.
Attachment #8347438 - Flags: approval-gaia-v1.3?(fabrice)
Comment on attachment 8347438 [details] [diff] [review]
patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 905208
[User impact] if declined: bad layout (see attachment)
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): safe, only CSS in a fairly contained location
[String changes made]: none

I'm asking approval on this patch because I'd like to land this one on 1.3. The changes that Steve is asking are too invasive for 1.3, I'll keep them for another patch.
Attachment #8347438 - Flags: approval-gaia-v1.3?(fabrice)
Blocks: 950795
master: 1f275beb53779feb31e1b00611c5e85428c431ae

Filed Bug 950795 to handle the minor refactoring that were asked by Steve.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attachment #8347438 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
triage: 1.3+
blocking-b2g: 1.3? → 1.3+
Uplifted 1f275beb53779feb31e1b00611c5e85428c431ae to:
v1.3: 88b3be5229241ebdec25190840bbc3b48a6bce8c
You need to log in before you can comment on or make changes to this bug.