When JWPlayer fallback is hit the title used winds up being the filename

VERIFIED FIXED

Status

Webmaker
Popcorn Maker
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mjschranz, Assigned: thecount)

Tracking

Details

(Reporter)

Description

4 years ago
I looked at the code and the problem simply is we don't pass along the proper title.

HTML5 videos that the browser supports get their URL trimmed and we use the filename on the end.

When we hit an error event, the passed in file url get's set to the title.

Updated

4 years ago
Assignee: nobody → scott
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Looks like this is fixed now.

I just tested it and I got a title using an mp4 in ff.

Closing this, reopen if you see it happening again or somewhere else.

I think the title was passed along with errorOptions.

I had to hack around hubble for the moment because of another bug, so going to put this on myself as needs verification until I can confirm it is working on prod.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(scott)
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Status: RESOLVED → VERIFIED
Flags: needinfo?(scott)
You need to log in before you can comment on or make changes to this bug.