Closed Bug 950107 Opened 6 years ago Closed 6 years ago

bootstrap.py does not honor proxy settings; times out even with properly defined http_proxy

Categories

(Firefox Build System :: General, defect, minor)

x86_64
macOS
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
mozilla30

People

(Reporter: thundarr, Assigned: makzmaciek)

Details

(Whiteboard: [mentor=gps][lang=python])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_1) AppleWebKit/537.73.11 (KHTML, like Gecko) Version/7.0.1 Safari/537.73.11

Steps to reproduce:

OS: OSX Mavericks 10.9
Internet access available only via a web proxy

$ env
http_proxy=http://web-proxy:8080
ALL_PROXY=http://web-proxy:8080

$ curl https://hg.mozilla.org/mozilla-central/raw-file/default/python/mozboot/bin/bootstrap.py > bootstrap.py 
$ python bootstrap.py
Could not load the bootstrap Python environment.

This should never happen. Consider filing a bug.

<urlopen error timed out>





Actual results:

Could not load the bootstrap Python environment.

This should never happen. Consider filing a bug.

<urlopen error timed out>



Expected results:

I hardcoded my os.environ[] proxy data to the bootstrap.py script:

 os.environ['http_proxy'] = 'web-proxy:8080'
 os.environ['https_proxy'] = 'web-proxy:8080'

And re-ran it with success.


<snip lots of Brew output>
Your version of Mercurial (2.8.1) is sufficiently modern.
Your version of Python (2.7.6) is new enough.

Your system should be ready to build Firefox! If you have not already,
obtain a copy of the source code by running:

    hg clone https://hg.mozilla.org/mozilla-central

Or, if you prefer Git:

    git clone https://git.mozilla.org/integration/gecko-dev.git
Severity: normal → minor
Hardware: x86 → x86_64
Yes, proxying http_proxy and https_proxy is probably all we need to do here.

Putting this into the mentored bugs pool. Should be pretty straightforward. Code in the tree at python/mozboot.
Whiteboard: [mentor=gps][lang=python]
Hi guys, I would like to work on this issue to make my first contribution.
Proposed patch, comments are welcome.

Could someone assign me to this bug please?
Assignee: nobody → makzmaciek
Comment on attachment 8371002 [details] [diff] [review]
0001-Bug-950107-proxy-settings-fix.patch

I'll review this.
Attachment #8371002 - Flags: review?(gps)
Comment on attachment 8371002 [details] [diff] [review]
0001-Bug-950107-proxy-settings-fix.patch

Review of attachment 8371002 [details] [diff] [review]:
-----------------------------------------------------------------

I didn't know about ALL_PROXY. Turns out it is a GNOME thing.

This patch looks good. I'll commit it for you.

Thank you for the contribution!
Attachment #8371002 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/3a620ff8ac4a
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.