[traceback] AttributeError: 'module' object has no attribute 'auth'

RESOLVED FIXED in 2013Q4

Status

support.mozilla.org
Questions
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: willkg, Assigned: mythmon)

Tracking

unspecified
2013Q4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=dunno p=1 s=2013.25)

Saw a bunch of error email from celery go by today with this error:


Task tidings.events._fire_task with id e91f53fb-fbe7-4fa8-8925-ae7352945caf raised exception:
'AttributeError("\'module\' object has no attribute \'auth\'",)'


Task was called with args: (<kitsune.questions.events.QuestionReplyEvent object at 0x53e05d0>,) kwargs: {'exclude': <User: XXXXXXXX>}.

The contents of the full traceback was:

Traceback (most recent call last):
  File "/data/www/support.mozilla.com/kitsune/vendor/src/celery/celery/execute/trace.py", line 181, in trace_task
    R = retval = fun(*args, **kwargs)
  File "/data/www/support.mozilla.com/kitsune/vendor/src/django-tidings/tidings/events.py", line 132, in _fire_task
    for m in self._mails(self._users_watching(exclude=exclude)):
  File "/data/www/support.mozilla.org/kitsune/kitsune/questions/events.py", line 104, in _mails
    auth_str = users.auth.get_auth_str(self.answer.question.creator)
AttributeError: 'module' object has no attribute 'auth'
Got the first one on 12/12/2013 at 7:57pm (no clue what timezone that is--might be EST or PST).

Have gotten 17 total. All exactly the same traceback.

This Sentry thing has a similar error and may or may not be related:

https://errormill.mozilla.org/support/support/group/153167/
This looks related to bug 928899 that went out last night. Assigning to :mythmon to take a look, please :)
Whiteboard: u=user c=dunno p= s=2013.25
Target Milestone: --- → 2013Q4
Assignee: nobody → mcooper
Priority: -- → P1
(Assignee)

Comment 3

5 years ago
I noticed these are all happening on the celery server, according to Sentry. That probably means mail isn't going out. I have a hypothesis that when we deployed this change, celery didn't pick up the code, for some reason. I think this because it is a pretty straight forward import statement that pulls in that file, and it is pretty easy to check that the file exists by looking at github. I'd like to re-deploy the current commit to prod, even though it is Friday, to try and fix this.
(Assignee)

Comment 4

5 years ago
The re-deploy didn't fix it. The real problem was a weird import thing that Will figured out.

PR: https://github.com/mozilla/kitsune/pull/1761
Landed in: https://github.com/rlr/kitsune/commit/6647a7dbb41943a07251586582c0af52548f76e6

I pushed this out to prod. I'm going to wait a little while to see if Sentry agrees with me before marking this as fixed.
(Assignee)

Comment 5

5 years ago
This hasn't re-occured for a while.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
This was probably 1 point.
Whiteboard: u=user c=dunno p= s=2013.25 → u=user c=dunno p=1 s=2013.25
You need to log in before you can comment on or make changes to this bug.