[B2G][Contacts]Imported Contacts Selection Screen from Gmail account displays inappropriate truncation and duplication text

VERIFIED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Assigned: arnau)

Tracking

(Blocks: 1 bug, {regression})

unspecified
1.3 C3/1.4 S3(31jan)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

(Whiteboard: visual design, visual-tracking, bokken, burirun1.3-1, burirun1.3-2)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8347369 [details]
ContactsImportGmailIssue

When user successfully imports Contacts from Gmail account on device, the selection screen for user to select all or some imported Gmail Contacts displays truncated and duplicate text. The Search bar is truncated. The number of found friends to import is truncated. When user scrolls on the page, some text is duplicated (i.e. The character D designated for all contacts that begin with the letter D is shown twice.)

Repro Steps:
1) Updated buri to BuildID: 20131213004002
2) Tap Contacts App
3) Tap gear icon in upper right for Contact Settings
4) Tap Import Contacts
5) Tap Gmail button
6) Message screen displays connection to display friend list

Actual:
Truncation and duplication of text appears. 

Expected:
Text appears normally - no duplication, no truncation

Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20131213004002
Gaia: 888f9df5515a47d2f5806efee77485e05e1e5416
Gecko: dfae9c83bfbc
Version: 28.0a2
RIL Version: 01.02.00.019.102


Notes:
Repro frequency: 100% 10/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/7059/
See attached: screenshot
(Reporter)

Comment 1

4 years ago
This issue does not reproduce on Buri 1.2 with the below Environmental Variables:

Environmental Variables:
Device: buri 1.2 MOZ
BuildID: 20131213004002
Gaia: 1aca7c4860e39b1a9969807d335dcf9f070ea9b3
Gecko: a2b69b561d9b
Version: 26.0
RIL Version: 01.02.00.019.102

Text appears normally with no truncation and no duplication on Contacts selection page.
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → affected
Keywords: regression, regressionwindow-wanted
Yuck. That looks like quite an ugly VD fallout from the 1.3 visual refresh.
blocking-b2g: --- → 1.3?

Updated

4 years ago
QA Contact: sparsons

Comment 3

4 years ago
This issue started to occur on the Buri 1.3 Build ID: 20131206040203


Gaia   8fca2ca67e8a6022fe6ed8cb576e5d59dfb5237f
SourceStamp 1401e4b394ad
BuildID 20131206040203
Version 28.0a1


Last working Buri 1.3 Build ID: 20131205040201

Gaia   1dd0e5c644b4c677a4e8fa02e50d52136db489d9
SourceStamp 725c36b5de1a
BuildID 20131205040201
Version 28.0a1
Keywords: regressionwindow-wanted

Updated

4 years ago
Assignee: nobody → pivanov

Updated

4 years ago
Blocks: 950756
Whiteboard: burirun1.3-1 → visual design, visual-tracking, bokken

Updated

4 years ago
Blocks: 950765
No longer blocks: 950756
triage: 1.3+ Regression
blocking-b2g: 1.3? → 1.3+

Updated

4 years ago
Duplicate of this bug: 952209
Whiteboard: visual design, visual-tracking, bokken → visual design, visual-tracking, bokken, burirun1.3-1
hi Pavel, do you mind providing some updates on this bug? Thanks
Flags: needinfo?(pivanov)
Hey Joe,

Sorry for the delay. I will start working on it these days because we landed the new [BB]Tabs and I realize that they affect this screen too.
Flags: needinfo?(pivanov)

Updated

4 years ago
Whiteboard: visual design, visual-tracking, bokken, burirun1.3-1 → visual design, visual-tracking, bokken, burirun1.3-1, burirun1.3-2

Comment 8

4 years ago
PM team triaged this and considers this a blocker for 1.3
Created attachment 8363970 [details] [review]
patch for Gaia/master
Attachment #8363970 - Flags: review?(jmcf)
since 1.3+ is the highest priority now, set target milestone, please make the change if it doesn't work. thanks
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)

Comment 11

4 years ago
Comment on attachment 8363970 [details] [review]
patch for Gaia/master

sorry Pavel, but the proposed change breaks the main contacts view. You have to take into account that fixed_header.css is shared between the import screen (import.html) and the main contacts one (index.html). 

Please have a look

thanks!
Attachment #8363970 - Flags: review?(jmcf) → review-
Assignee: pivanov → arnau
Hey Pavel, while working on bug 950803 I saw the solution to that bug, not far from what you proposed, so let me create a patch for you ;)
Created attachment 8365885 [details]
patch in github
Attachment #8363970 - Attachment is obsolete: true
Attachment #8365885 - Flags: review?(jmcf)
Hey Arnau,

I do the same thing :) but don't have a connection to update the PR ... :) thanks for the patch :)
So f+ from me :)

Comment 15

4 years ago
Comment on attachment 8365885 [details]
patch in github

thanks Arnau. works perfectly
Attachment #8365885 - Flags: review?(jmcf) → review+

Comment 16

4 years ago
https://github.com/mozilla-b2g/gaia/commit/d4d8c7d1bae2e9447be13d678b200f294d04f8b7
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Uplifted d4d8c7d1bae2e9447be13d678b200f294d04f8b7 to:
v1.3: 4d79378e0eef52992ed4d05ad3ee4573002179cf
status-b2g-v1.3: affected → fixed

Comment 18

4 years ago
Hi, 
Please see video file attached, although it is not possible to reproduce the bug as it was reported, there is still a way that scrolling down and up, shows the A label twice, over the search box and above the contacts. 
Should we verify this bug an open a new one for that? Thanks!

Comment 19

4 years ago
Created attachment 8367357 [details]
A label appears twice
(In reply to Isabel Rios [:isabel_rios] from comment #19)
> Created attachment 8367357 [details]
> A label appears twice

Hi Isabel, Have you found this new bug in master? v1.3? both?
Flags: needinfo?(isabelrios)

Comment 21

4 years ago
Hi, 
I found this when trying to verify this bug, with today's (01/29) 1.3 buri build:
Gecko-9c7f92f
Gaia-77fdf05
Flags: needinfo?(isabelrios)
(In reply to Isabel Rios [:isabel_rios] from comment #21)
> Hi, 
> I found this when trying to verify this bug, with today's (01/29) 1.3 buri
> build:
> Gecko-9c7f92f
> Gaia-77fdf05

Thanks Isabel,
Arnau, can you have a look at it?
Flags: needinfo?(arnau)
Should we create a new bug for this? instead of reopening that one which is already uplifted and solves a much undesired behavior.
Flags: needinfo?(arnau)
(In reply to Arnau March from comment #23)
> Should we create a new bug for this? instead of reopening that one which is
> already uplifted and solves a much undesired behavior.

yes, I think we should open a new bug. Isabel, can you create it, please? Thanks a lot!

Comment 25

4 years ago
Already filed: Bug 966898

Comment 26

4 years ago
And then, this bug can be verified.
Status: RESOLVED → VERIFIED
Tested (02/03/2014) and working:
1.3
Gecko e01ea79
Gaia f9a37c7
Blocks: 948791
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
You need to log in before you can comment on or make changes to this bug.