Permanent leak with http://chat.meatspac.es/

RESOLVED DUPLICATE of bug 919244

Status

()

Core
WebRTC: Audio/Video
RESOLVED DUPLICATE of bug 919244
4 years ago
4 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

(Reporter)

Description

4 years ago
Steps to reproduce:

1. Go to http://chat.meatspac.es/
2. While the camera permissions dialogue is up, close the tab.

Now if you could to about:memory, click "minimize memory usage", then "measure", you'll see this:

20.16 MB (05.08%) -- top(none)/ghost/window(https://chat.meatspac.es/)

(it may not say ghost window immediately, but it will still be there)

This is bad because we're leaking 20mb forever (it was hanging around for quite a while), and because it is a leak, the CC gets really slow (55ms vs more like 5ms otherwise).

I'm not sure if it is required to close the tab before the permissions dialogue is gone or not, but my guess would be it is somehow related to that, because we've seen similar things before.
(Reporter)

Comment 1

4 years ago
Kyle points out that it is probably the same thing as bug 919244.
Depends on: 919244
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 919244
You need to log in before you can comment on or make changes to this bug.