Bug 950175 (sms-visual-refresh)

[meta] Messaging Visual Refresh

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: padamczyk, Unassigned)

Tracking

({meta})

unspecified
x86
Mac OS X
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, bokken, [ucid:, 2.0, ft:comms] )

Attachments

(18 attachments, 25 obsolete attachments)

25.25 KB, image/png
Details
46.94 KB, image/png
Details
43.71 KB, image/png
Details
18.58 KB, image/png
Details
17.27 KB, image/png
Details
17.15 KB, image/png
Details
20.92 KB, image/png
Details
18.75 KB, image/png
Details
27.69 KB, image/png
Details
51.77 KB, image/png
Details
56.08 KB, image/png
Details
964 bytes, image/svg+xml
Details
67.45 KB, image/png
Details
229.41 KB, application/zip
Details
1.27 MB, application/pdf
Details
75.02 KB, image/png
Details
22.85 KB, image/png
Details
56.95 KB, image/png
Details
(Reporter)

Description

5 years ago
Meta bug for visual design refresh of the messaging app
(Reporter)

Updated

5 years ago
No longer depends on: 950172
(Reporter)

Updated

5 years ago
Blocks: 950177
(Reporter)

Updated

5 years ago
No longer blocks: 950177
Depends on: 950177
(Reporter)

Updated

5 years ago
Alias: 1.4-MSG-Refresh
(Reporter)

Updated

5 years ago
Alias: 1.4-MSG-Refresh → MSG-VSD-Refresh
(Reporter)

Updated

5 years ago
Blocks: 950208
(Reporter)

Updated

5 years ago
No longer blocks: 950208
(Reporter)

Updated

5 years ago
Depends on: 930364
(Reporter)

Updated

5 years ago
Depends on: 930569
(Reporter)

Updated

5 years ago
Blocks: 950751
(Reporter)

Updated

5 years ago
No longer blocks: 950751
(Reporter)

Updated

5 years ago
Blocks: 950756
(Reporter)

Updated

5 years ago
No longer blocks: 950756
(Reporter)

Updated

5 years ago
Alias: MSG-VSD-Refresh → Messaging-1.4-VSD
Summary: [VsD Refresh][Meta] Messaging Visual Updates → [meta] 1.4 Messaging Visual Refresh
(Reporter)

Updated

5 years ago
Blocks: 965889
(Reporter)

Updated

5 years ago
No longer blocks: 965889

Updated

5 years ago
Depends on: 951676

Updated

5 years ago
Depends on: 951682

Updated

5 years ago
Depends on: 951672

Updated

5 years ago
Depends on: 951687
Created attachment 8369949 [details]
VDR Mockup: Compose. invalid recipient
Created attachment 8369951 [details]
VDR Mockup: Compose. empty
Created attachment 8369952 [details]
VDR Mockup: Compose. 1 recipient
Created attachment 8369953 [details]
VDR Mockup: Compose. 4 recipients
Created attachment 8369954 [details]
VDR Mockup: Compose. recipient hit state
Created attachment 8369955 [details]
VDR Mockup: Compose. Long message

Updated

5 years ago
Depends on: 917822
No longer depends on: 917822
Created attachment 8370022 [details]
VDR Mockup: Messages Inbox
Created attachment 8370067 [details]
VDR Mockup: Messages thread idle mode
Created attachment 8370068 [details]
VDR Mockup: Messages thread Edit mode
(In reply to Victoria Gerchinhoren from comment #5)
> Created attachment 8369954 [details]
> VDR Mockup: Compose. recipient hit state

Generally, "hit state" refers to the state when a mouse click or finger tap occurs, but there is already a "hit state" for all recipients: they flip into "editable" mode.
Created attachment 8370690 [details]
VDR Mockup: Messages Inbox edit mode
Created attachment 8370691 [details]
VDR Mockup: Messages thread Edit mode
Attachment #8370068 - Attachment is obsolete: true
Created attachment 8370693 [details]
VDR Mockup: Messages thread idle mode
Attachment #8370067 - Attachment is obsolete: true
Created attachment 8370728 [details]
Visual refresh Spec for Messaging

This documents points out the changes to be made in order to visually refresh the app for V1.4 in a reduced scope version.
(In reply to Rick Waldron [:rwaldron] from comment #10)
> (In reply to Victoria Gerchinhoren from comment #5)
> > Created attachment 8369954 [details]
> > VDR Mockup: Compose. recipient hit state
> 
> Generally, "hit state" refers to the state when a mouse click or finger tap
> occurs, but there is already a "hit state" for all recipients: they flip
> into "editable" mode.

The moment between still mode and the editable mode is this hitstate as we need to provide feedback to the user when tapping.

Updated

5 years ago
Alias: Messaging-1.4-VSD → Messaging-1.5-VSD
Summary: [meta] 1.4 Messaging Visual Refresh → [meta] 1.5 Messaging Visual Refresh

Comment 16

5 years ago
Flagging Wilfred so he is aware of this work.
Flags: needinfo?(wmathanaraj)

Updated

5 years ago
Depends on: 980461

Updated

5 years ago
Blocks: 985426
Whiteboard: ux-tracking, visual design, visual-tracking, bokken → ux-tracking, visual design, visual-tracking, bokken, [ucid:, 1.5, ft:comms]
Depends on: 985995
Depends on: 963109
Created attachment 8394707 [details]
Visual refresh Spec for Messaging
Attachment #8370728 - Attachment is obsolete: true

Updated

5 years ago
Depends on: 986433
Created attachment 8394730 [details]
VDR Mockup: Compose. invalid recipient
Attachment #8369949 - Attachment is obsolete: true
Created attachment 8394741 [details]
VDR Mockup: Compose. invalid recipient
Attachment #8394730 - Attachment is obsolete: true
Created attachment 8394743 [details]
VDR Mockup: Compose. empty
Attachment #8369951 - Attachment is obsolete: true
Created attachment 8394744 [details]
VDR Mockup: Compose. 1 recipient
Attachment #8369952 - Attachment is obsolete: true
Created attachment 8394747 [details]
VDR Mockup: Compose. 4 recipients
Attachment #8369953 - Attachment is obsolete: true
Created attachment 8394748 [details]
VDR Mockup: Compose. recipient hit state
Attachment #8369954 - Attachment is obsolete: true
Created attachment 8394749 [details]
VDR Mockup: Compose. Long message
Attachment #8369955 - Attachment is obsolete: true
Created attachment 8394750 [details]
VDR Mockup: Messages Inbox
Attachment #8370022 - Attachment is obsolete: true
Created attachment 8394780 [details]
VDR Mockup: Messages thread idle mode
Attachment #8370693 - Attachment is obsolete: true
Created attachment 8394783 [details]
VDR Mockup: Compose. invalid recipient
Attachment #8394741 - Attachment is obsolete: true
Created attachment 8394784 [details]
VDR Mockup: Compose. empty
Attachment #8394743 - Attachment is obsolete: true
Created attachment 8394786 [details]
VDR Mockup: Compose. 1 recipient
Attachment #8394744 - Attachment is obsolete: true
Created attachment 8394787 [details]
VDR Mockup: Compose. 4 recipients
Attachment #8394747 - Attachment is obsolete: true
Created attachment 8394788 [details]
VDR Mockup: Compose. recipient hit state
Attachment #8394748 - Attachment is obsolete: true
Created attachment 8394789 [details]
VDR Mockup: Compose. Long message
Attachment #8394749 - Attachment is obsolete: true
Created attachment 8394790 [details]
VDR Mockup: Messages Inbox
Attachment #8394750 - Attachment is obsolete: true
Created attachment 8394791 [details]
Visual refresh Spec for Messaging
Attachment #8394707 - Attachment is obsolete: true
I have just updated all the documentation to reflect the color change in the Comms Headers. This green color happens only for the Comms Apps and it is part of a larger intention of theming the different apps of the system grouping them by type (Media, Productivity, Comms and Settings).

This change will happen at a Building Block level, so it does not mean any extra effort from the Comms team. (https://bugzilla.mozilla.org/show_bug.cgi?id=985995)

Thanks.
(In reply to Victoria Gerchinhoren [:vicky] from comment #35)

> This change will happen at a Building Block level, so it does not mean any
> extra effort from the Comms team.
> (https://bugzilla.mozilla.org/show_bug.cgi?id=985995)
> 
> Thanks.

If I'm not wrong we'll still need to add something in our markup so that the correct CSS applies.

Thanks Victoria for the various mockups!
> 
> If I'm not wrong we'll still need to add something in our markup so that the
> correct CSS applies.
> 

Yes, we will add class="skin-comms" to all comms apps (if possible in the body of each HTML), and will use that class in all BB that needs to be customized.
Same way we are doing right now in headers BB with skin-organic and skin-dark.

Updated

4 years ago
Summary: [meta] 1.5 Messaging Visual Refresh → [meta] Messaging Visual Refresh

Updated

4 years ago
Alias: Messaging-1.5-VSD → Messaging-VSD

Updated

4 years ago
Target Milestone: --- → 1.5 S1 (9may)

Updated

4 years ago
No longer depends on: 930569

Updated

4 years ago
Alias: Messaging-VSD → Messaging-Refresh

Updated

4 years ago
Alias: Messaging-Refresh → Messaging

Updated

4 years ago
Alias: Messaging
Created attachment 8397150 [details]
New files place holders for Messaging thread.
Created attachment 8397168 [details]
Refreshed thumbnails for file placeholders
Attachment #8397150 - Attachment is obsolete: true
Created attachment 8397180 [details]
Mockup of how the thread should look like with the new placeholders

Comment 41

4 years ago
Created attachment 8397790 [details]
Asset. SVG play overlay

Play to place overlaying the video frame thumbnail.

Comment 42

4 years ago
Created attachment 8397793 [details]
Mockup of how the thread should look like with the new placeholders. Video frame
Created attachment 8398449 [details]
Refreshed thumbnails for file placeholders
Attachment #8397168 - Attachment is obsolete: true
Updated the placeholders .zip including the hitstates.

Updated

4 years ago
Depends on: 989899
Depends on: 949457
Depends on: 990518
Depends on: 990528
Depends on: 990537
Summary: [meta] Messaging Visual Refresh → (Messaging VDR) [meta] Messaging Visual Refresh
Flags: needinfo?(wmathanaraj)

Updated

4 years ago
Depends on: 991094

Updated

4 years ago
Assignee: nobody → joan.leon

Updated

4 years ago
Assignee: joan.leon → nobody
Depends on: 992946
Created attachment 8403322 [details]
Visual refresh Spec for Messaging (2)

Changed a note, the time stamp color in the green bubbles inside the messages thread.
Attachment #8394791 - Attachment is obsolete: true

Comment 46

4 years ago
Created attachment 8403467 [details] [review]
Path in github
Attachment #8403467 - Flags: review?(borja.bugzilla)

Comment 47

4 years ago
Comment on attachment 8403467 [details] [review]
Path in github

This patch it's for composer
Joan, can you please file a separate bug for this patch?
Flags: needinfo?(joan.leon)

Comment 49

4 years ago
Created attachment 8403469 [details]
VR_Message_Composer.zip

Screenshots of Composer
Attachment #8403469 - Flags: ui-review?(vpg)

Updated

4 years ago
Attachment #8403469 - Attachment is obsolete: true
Attachment #8403469 - Flags: ui-review?(vpg)
Flags: needinfo?(joan.leon)

Comment 50

4 years ago
Comment on attachment 8403467 [details] [review]
Path in github

Move to bug 963018
Attachment #8403467 - Attachment is obsolete: true
Attachment #8403467 - Flags: review?(borja.bugzilla)

Comment 51

4 years ago
Comment on attachment 8403469 [details]
VR_Message_Composer.zip

Move to bug 963018

Updated

4 years ago
Depends on: 994498
No longer depends on: 994498
Duplicate of this bug: 994987

Updated

4 years ago
Depends on: 996889
blocking-b2g: --- → backlog
Whiteboard: ux-tracking, visual design, visual-tracking, bokken, [ucid:, 1.5, ft:comms] → ux-tracking, visual design, visual-tracking, bokken, [ucid:, 2.0, ft:comms]
Created attachment 8408358 [details]
Visual SPEC: Thread_colors

New bubble's color spec
As per discussed in bug 985995, please update the bubbles backgrpund and text color to get a better contrast and legibility.

Thanks!

Updated

4 years ago
blocking-b2g: backlog → 2.0?
Reset the blocking-b2g flag to backlog.
For COMMS team's committed feature, it blocks the meta bug comms_2.0.
blocking-b2g: 2.0? → backlog
Hey Victoria, 

I've checked the new bubble's color spec, and it looks good regarding accessibility ! Thanks !

Updated

4 years ago
No longer depends on: 1003060

Updated

4 years ago
Depends on: 1003060

Updated

4 years ago
Depends on: 1003789

Comment 57

4 years ago
Created attachment 8417859 [details]
VDR Mockup: Compose. Contacts Suggestions

Contacts Suggestions visual mockup.

Updated

4 years ago
Target Milestone: 2.0 S1 (9may) → ---
feature-b2g: --- → 2.0
Summary: (Messaging VDR) [meta] Messaging Visual Refresh → (sms-visual-refresh) [meta] Messaging Visual Refresh
Alias: sms-visual-refresh
Summary: (sms-visual-refresh) [meta] Messaging Visual Refresh → [meta] Messaging Visual Refresh
Victoria, one question about the composer view:
where should be the "To:" label when there are several lines of recipients and the user slides down the recipient panel? Should the "To:" label slide down along the last recipient line, or should it stay at the same place, or you don't mind?
Flags: needinfo?(vpg)
(In reply to Julien Wajsberg [:julienw] from comment #58)
> Victoria, one question about the composer view:
> where should be the "To:" label when there are several lines of recipients
> and the user slides down the recipient panel? Should the "To:" label slide
> down along the last recipient line, or should it stay at the same place, or
> you don't mind?

Hi Julien,
This was already asked by Joan, I think the best is that slides down with the last recipients, so it lines up with the "+" button and the area where further recipients are added.

Thanks!
Flags: needinfo?(vpg)

Updated

4 years ago
Depends on: 1010093

Updated

4 years ago
Depends on: 1010301
Flags: in-moztrap?(nhirata.bugzilla)

Updated

4 years ago
Depends on: 1013296
Depends on: 1014178
QA Contact: echang
Functional Regression test cases
http://mzl.la/1jWCccD
Created attachment 8429571 [details]
Visual SPEC: carrier and date subheaders
Duplicate of this bug: 1018058
Clear feature-b2g flag for this is meta bug which may include bigger set rather than must-have feature works.
feature-b2g: 2.0 → ---
No longer blocks: 1026943
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
handled under various SMS tests
Flags: in-moztrap?(nhirata.bugzilla) → in-moztrap+
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.