Closed Bug 950182 Opened 6 years ago Closed 6 years ago

[B2G][Contacts]Tapping on Windows Live page field to insert username to import contacts from hotmail or outlook shows overlap of two pages

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.2 unaffected, b2g-v1.3 affected)

RESOLVED DUPLICATE of bug 948875
Tracking Status
b2g-v1.2 --- unaffected
b2g-v1.3 --- affected

People

(Reporter: mclemmons, Assigned: alive)

Details

(Keywords: regression, Whiteboard: burirun1.3-1, [FT:System-Platform])

Attachments

(2 files)

When user taps Microsoft account field labeled someone@example.com after importing contacts from outlook on device, the keyboard pops up, the cursor blinks on the username field but the previous page text displays in sections (Import Contacts page).

Repro Steps:
1) Updated buri to BuildID: 20131213004002
2) Tap Contacts 
3) Tap gear icon in upper right to settings area for Contacts
4) Tap Import Contacts button
5) Tap Outlook button
6) After login.live.com page displays, tap on username field

Actual:
Keyboard pops up. Cursor blinks in username field. Between username and keyboard shows the truncated text of Outlook from the Import Contacts button page.

Expected:
Keyboard pops up. Cursor blinks in username field. Password field shows between keyboard and username field. No text from Import Contacts button page displays.

Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20131213004002
Gaia: 888f9df5515a47d2f5806efee77485e05e1e5416
Gecko: dfae9c83bfbc
Version: 28.0a2
RIL Version: 01.02.00.019.102


Notes:
Repro frequency: 100% 10/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/7226/
See attached: screenshot
This issue does not reproduce on Buri v 1.2 with the below Environmental Variables 

Environmental Variables: 
Device: buri 1.2 MOZ 
BuildID: 20131213004002 
Gaia: 1aca7c4860e39b1a9969807d335dcf9f070ea9b3 
Gecko: a2b69b561d9b 
Version: 26.0 
RIL Version: 01.02.00.019.102

There is no overlap of other device page text on the login.live.com page.
Can you get a video of this bug?
QA Contact: gbennett
Video of repro on Buri 1.3 mozRIL: http://www.youtube.com/watch?v=fFNICL6UvK0

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131213004002
Gaia: 888f9df5515a47d2f5806efee77485e05e1e5416
Gecko: dfae9c83bfbc
Version: 28.0a2
RIL Version: 01.02.00.019.102
Firmware Version: 20131115
Keywords: qawanted
Looks like we're bleeding UI through the app via the keyboard then. Yuck.
blocking-b2g: --- → 1.3?
Component: Gaia::Contacts → Gaia::Keyboard
No, this is a window management & iframe sizing issue, which is caused by another bug (no?) that mistakenly shows Contact app in full screen w/o status bar.

Alive, could you fix the size and the position of the pop-up on top of full screen app? This happens on v1.4 as well.

Could someone identify the bug on Contact app which makes it full screen? Is it a bug on window management on apps with entry points or a Contact app bug?

Triage: +'ing, serous UI breakage.
blocking-b2g: 1.3? → 1.3+
Component: Gaia::Keyboard → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
Whiteboard: burirun1.3-1 → burirun1.3-1, [FT:System-Platform]
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #5)
> No, this is a window management & iframe sizing issue, which is caused by
> another bug (no?) that mistakenly shows Contact app in full screen w/o
> status bar.

https://bugzilla.mozilla.org/show_bug.cgi?id=948875

> 
> Alive, could you fix the size and the position of the pop-up on top of full
> screen app? This happens on v1.4 as well.
>
Assignee: nobody → alive
Flags: needinfo?(alive)
QA Contact: gbennett → nkot
it seems that bug 948875 is causing this bug as well as these collection of bugs - see https://bugzilla.mozilla.org/show_bug.cgi?id=949201#c8

regression window is the same for all:

~works~
BuildID: 20131210004003
Gaia: 3452fbdb5e1bed0cd27cc6173136537a03e8072f
Gecko: e0c328d99742
Version: 28.0a2

~broken~
BuildID: 20131211004003
Gaia: 7a2ccae2a546ac4d981d250272dafa630c926422
Gecko: 6bb84d0bc170
Version: 28.0a2
For video repro use: http://www.youtube.com/watch?v=eZUXMkL7J4E&edit=vd instead of the one in comment 3.
(In reply to Alive Kuo [:alive][NEEDINFO][OOO:12/24-1/4] from comment #6)
> (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from
> > Alive, could you fix the size and the position of the pop-up on top of full
> > screen app? This happens on v1.4 as well.
> >

De-non because the sizing issue has been always there, and Gaia core apps does not use fullscreen and pop-up together under the right conditions.
blocking-b2g: 1.3+ → 1.3?
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #9)
> (In reply to Alive Kuo [:alive][NEEDINFO][OOO:12/24-1/4] from comment #6)
> > (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from
> > > Alive, could you fix the size and the position of the pop-up on top of full
> > > screen app? This happens on v1.4 as well.
> > >
> 
> De-non because the sizing issue has been always there, and Gaia core apps
> does not use fullscreen and pop-up together under the right conditions.

That's an incorrect analysis. comment 7 cites a clear regression range that proves this is a regression within the 1.3 timeframe. Additionally, this has nothing to do with fullscreen apps - the bug here is dealing with windows live site usage in a pop-up as part of the contacts app, which is not a fullscreen app.
(In reply to Jason Smith [:jsmith] from comment #10)
> (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from
> comment #9)
> > (In reply to Alive Kuo [:alive][NEEDINFO][OOO:12/24-1/4] from comment #6)
> > > (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from
> > > > Alive, could you fix the size and the position of the pop-up on top of full
> > > > screen app? This happens on v1.4 as well.
> > > >
> > 
> > De-non because the sizing issue has been always there, and Gaia core apps
> > does not use fullscreen and pop-up together under the right conditions.
> 
> That's an incorrect analysis. comment 7 cites a clear regression range that
> proves this is a regression within the 1.3 timeframe. Additionally, this has
> nothing to do with fullscreen apps - the bug here is dealing with windows
> live site usage in a pop-up as part of the contacts app, which is not a
> fullscreen app.

Note - this could potentially happen with third-party apps that chose to use pop-up authentication with windows live, which is definitely possible. So this has partner content impact as well.
The sizing issue itself is not a regression, the regression range is there due to the contacts app going full screen incorrectly (bug 948875, which is fixed).  We should remove the regression keyword here. 
As for 1.3 blocking triage, this behavior has stayed the same since 1.0, so let's backlog it for now.
Blocks: 908549
blocking-b2g: 1.3? → ---
(In reply to Bruce Huang [:bhuang] <bhuang@mozilla.com> from comment #12)
> The sizing issue itself is not a regression, the regression range is there
> due to the contacts app going full screen incorrectly (bug 948875, which is
> fixed).  We should remove the regression keyword here. 
> As for 1.3 blocking triage, this behavior has stayed the same since 1.0, so
> let's backlog it for now.

That just implies bug 948875 was the reason why we were seeing this bug, but the behavior itself is still a regression in the context of the contacts app. It's still regression however in terms of behavior of the contacts app, as that's what the bug filer intended the bug to focus on. Reflipping flags & renoming until there's confirmation bug 948875 fixed this bug.

Please don't morph bugs without context in the future when the bug filer has clearly provided data on what the regression of the bug is focusing on. Thanks.
No longer blocks: 908549
blocking-b2g: --- → 1.3?
Keywords: regression
Keywords: qawanted
QA Wanted to confirm this is fixed on trunk.
Attached image screenshot_fixed
appears as fixed on master 

Device: Buri v.1.4 Mozilla RIL
BuildID: 20140107040206
Gaia: 9f30198a420632359b271de7e680abde92ccbcd6
Gecko: e7a366c1036c
Version: 29.0a1
Firmware Version: v1.2_20131115
Keywords: qawanted
Guess that confirms this is a dupe of bug 948875.
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 948875
You need to log in before you can comment on or make changes to this bug.