[E-mail][V1.3] A dotted line is displayed on the header bar

VERIFIED FIXED in Firefox OS v1.3

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: whsu, Assigned: pdahiya)

Tracking

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 verified, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

(Whiteboard: [ft:productivity])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8347410 [details]
WP_20131214_004.mp4

* Description:
  While you tap menu icon to show the folder list, a dotted line will be displayed on the header bar after you go back to inbox page.
  Attaching the video. (WP_20131214_004.mp4)

* Reproduction steps:
  1. Launch the email app
  2. Go to inbox
  3. Tapping menu icon to switch to folder list
  4. Tapping menu icon again to go back to inbox

* Expected result:
  All UIs are displayed as normal

* Actual result:
  A dotted line is displayed on the header bar

* Test build:(V1.3)
 - Gaia:     588a3e02c4ace3b3341ba1f6bb7274120b53b2b3
 - Gecko:    http://hg.mozilla.org/releases/mozilla-aurora/rev/031270be3702
 - BuildID   20131212004003
 - Version   28.0a2
(Reporter)

Updated

5 years ago
Whiteboard: [ft:productivity]
(Reporter)

Comment 1

5 years ago
A UI defect. We can consider to fix it on V1.3 or latest build.
blocking-b2g: --- → 1.3?
triage: feels like a significant enough papercut to justify blocking on this for 1.3
blocking-b2g: 1.3? → 1.3+
maybe do a `event.preventDefault()` inside the `touchstart` handler, that would prevent the `focus()` or maybe just do a `blur()` on the element after `click`.

PS: I'm unsure how this is implemented internally and don't know if the `:focus` style is needed for accessibility (so it might not be a good idea to remove it). Just a suggestion of what could be a quick fix.
(Assignee)

Updated

5 years ago
Assignee: nobody → pdahiya
(Assignee)

Comment 4

5 years ago
Created attachment 8357944 [details] [review]
PR with fix of dotted line in header

In fix of Bug 917812,  shared/style/headers.css is updated by removing outline:none style from first anchor element in header.
https://github.com/mozilla-b2g/gaia/commit/71d9a0c80df5ad3d62a47531eb53651e077f8a6c

I propose to add outline:none back on anchor element to fix the dotted line issue in email header. 

Arnau, Please review attached PR. Thanks
Attachment #8357944 - Flags: review?(arnau)
Commented in GH, the patch works but I think we could reduce rules :)
Thanks
(Assignee)

Comment 6

5 years ago
Hi Arnau
Tested and updated PR with review feedback. Please review
Thanks
Comment on attachment 8357944 [details] [review]
PR with fix of dotted line in header

Looks good to me. Thanks!
Attachment #8357944 - Flags: review?(arnau) → review+
(Assignee)

Comment 8

5 years ago
Thanks Arnau for review. Fix merged with master https://github.com/mozilla-b2g/gaia/commit/4776e906f35b9d837f6c1f9ecea855493a73824f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 4776e906f35b9d837f6c1f9ecea855493a73824f to:
v1.3: 6ce260d19f6ede27c299d2258f469571f743f9f7
status-b2g-v1.3: --- → fixed
(Reporter)

Comment 10

5 years ago
Thanks.
I cannot reproduce this bug on latest V1.3 build.
Mark as "VERIFIED"


*Build Information:
 - Gaia      26e8a950f3ac703310ee8efcb741ff2418e9d190
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/ecdc275e9741
 - BuildID   20140217004003
 - Version   28.0

* Test Result:
 - Cannot reproduce
Status: RESOLVED → VERIFIED
(Reporter)

Updated

5 years ago
status-b2g-v1.3: fixed → verified
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
You need to log in before you can comment on or make changes to this bug.