[PP] apprunner crashes when messenger window is minimized

VERIFIED FIXED in M8

Status

SeaMonkey
MailNews: Message Display
P3
major
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: jay, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If you try to minimize the messenger window, apprunner crashes

Steps:
1. launch apprunner, launch messenger
2. minimize messenger window
3. crash

Machine and Build:
win98 build 1999070908

NOTE:
This was not a problem with linux 1999070908 or mac 1999070908

Other Comments:
This seems to only happenw with the messenger window...minimizing apprunner,
ender, plaintext editor and manage history windows does not crash.

Updated

19 years ago
Summary: apprunner crashes when messenger window is minimized → [PP] apprunner crashes when messenger window is minimized

Comment 1

19 years ago
Not good.  cc: putterman and bienvenu.
Jay - do you have a Talkback incident report for this?

Updated

19 years ago
Assignee: phil → hyatt

Comment 2

19 years ago
Here's the stack trace - it seems layout or tree control-related. perhaps it's
related to the general tree control problems. Re-assigning to David to look at.

nsTreeRowGroupFrame::ContinueReflow(nsIPresContext & {...}, int 0x00000000, int
0x00000000) line 924 + 16 bytes
nsTableRowGroupFrame::ReflowMappedChildren(nsTableRowGroupFrame * const
0x020f2e20, nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
RowGroupReflowState & {...}, unsigned int & 0x00000000, nsTableRowFrame *
0x00000000, nsReflowReason eReflowReason_Resize, int 0x00000001) line 398 + 32
bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x020f2e24,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0x00000000) line 1018 + 39 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x020f2e20, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 392 + 28 bytes
nsTableFrame::ReflowMappedChildren(nsTableFrame * const 0x020e9bb0,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, InnerTableReflowState &
{...}, unsigned int & 0x00000000) line 3818 + 31 bytes
nsTableFrame::ResizeReflowPass2(nsTableFrame * const 0x020e9bb0, nsIPresContext
& {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0x00000000) line 2888 + 31 bytes
nsTableFrame::Reflow(nsTableFrame * const 0x020e9bb4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 2591 + 38 bytes
nsTreeFrame::Reflow(nsTreeFrame * const 0x020e9bb4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 286
nsContainerFrame::ReflowChild(nsIFrame * 0x020e9bb0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 392 + 28 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x020e9cc4, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0x00000000) line 1006 + 37 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x020e9cc0, const nsRect & {...},
int 0x00000000, int 0x00000000, int 0x00000001, nsMargin & {...}, unsigned int &
0x00000000) line 227 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x020f2c60, int * 0x00128c30) line 2524 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x020f2c60, int
* 0x00128c30) line 2014 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1824 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x020e8414, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 1199 + 18 bytes
nsBoxFrame::FlowChildAt(nsIFrame * 0x020e8410, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000, int 0x00000001, nsIFrame * & 0x00000000) line 711
nsBoxFrame::FlowChildAt(nsIFrame * 0x020e8410, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000, int 0x00000001, nsIFrame * & 0x00000000) line 685
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0x00000000, nsRect & {...},
nsIFrame * & 0x00000000) line 411
nsBoxFrame::Reflow(nsBoxFrame * const 0x00e4d7b4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 285
nsContainerFrame::ReflowChild(nsIFrame * 0x00e4d7b0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 392 + 28 bytes
RootFrame::Reflow(RootFrame * const 0x020e4474, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 242
nsContainerFrame::ReflowChild(nsIFrame * 0x020e4470, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 392 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x020df4a4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
0x00000000) line 440
PresShell::ResizeReflow(PresShell * const 0x01cd8480, int 0x000003cf, int
0x00000096) line 992
PresShell::ResizeReflow(PresShell * const 0x01cd8484, nsIView * 0x01cd8930, int
0x000003cf, int 0x00000096) line 2127
nsViewManager::SetWindowDimensions(nsViewManager * const 0x01cd8b50, int
0x000003cf, int 0x00000096) line 356
nsViewManager::DispatchEvent(nsViewManager * const 0x01cd8b50, nsGUIEvent *
0x0012b6ec, nsEventStatus & nsEventStatus_eIgnore) line 1596
HandleEvent(nsGUIEvent * 0x0012b6ec) line 67
nsWindow::DispatchEvent(nsWindow * const 0x01cd8804, nsGUIEvent * 0x0012b6ec,
nsEventStatus & nsEventStatus_eIgnore) line 434 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012b6ec) line 455
nsWindow::OnResize(nsRect & {...}) line 3046 + 15 bytes
nsWindow::ProcessMessage(unsigned int 0x00000047, unsigned int 0x00000000, long
0x0012b960, long * 0x0012b8f0) line 2539 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x010501be, unsigned int 0x00000047, unsigned int
0x00000000, long 0x0012b960) line 503 + 27 bytes
(Reporter)

Comment 3

19 years ago
since the stack trace has already been given, here is my incident id: 10964108
if you need it.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
I'm not seeing this any more.  Marking fixed.

Comment 5

19 years ago
I'm still seeing this, and I think I've pulled all the interesting changes.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 6

19 years ago
Sorry to do this, but I'm still seeing this and I have all of your changes.  So
I'm going to reopen.

Updated

19 years ago
Resolution: FIXED → ---
(Assignee)

Comment 7

19 years ago
Ok, interesting.  I can't reproduce it on my machine.  I could add a null
check to stop the crash, but the values that you have to have to see this
crash indicate something wacky is going on.

I'm even using win98.

Comment 8

19 years ago
Have you opened a folder? It might have to do with having something in the
thread pane.
(Assignee)

Comment 9

19 years ago
*** Bug 9380 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

19 years ago
Fixed with recent checkin.

Comment 11

19 years ago
Yep, works for me now. cool.

Updated

19 years ago
Target Milestone: M8

Comment 12

19 years ago
setting target milestone from blank to M8.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 13

19 years ago
claudius and i agree: verified with the friday, 1999-07-09-08 builds.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.