[PDF Viewer] Missing text with hardware acceleration enabled

RESOLVED DUPLICATE of bug 978276

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED DUPLICATE of bug 978276
5 years ago
3 years ago

People

(Reporter: jaulmerd, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-windows][pdfjs-d-hwa-on])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
http://llvm.org/devmtg/2013-11/slides/Rotem-Vectorization.pdf

Diabling HWA fixes it.

Tested on Win7 & Win8 machines with different graphics adapters (Direct3D 10 and DirectWrite capable).
Also reported upstream, see: https://github.com/mozilla/pdf.js/issues/4021.

Comment 2

5 years ago
Created attachment 8347631 [details]
Rotem-Vectorization.1-2.pdf

Only pages 1&2 showing the issue.

Updated

5 years ago
Summary: PDF: missing text with hardware acceleration (Directon → [PDF Viewer] Missing text with hardware acceleration enabled
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Reproduced on latest Aurora (20131216004006), setting as New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-windows][pdfjs-d-hwa-on]
Blocks: 978276
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 978276
You need to log in before you can comment on or make changes to this bug.