Addon SDK panel resize issue in Firefox 26

RESOLVED FIXED

Status

Add-on SDK
General
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Mingyi Liu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

In my addon, I call panel.resize(width, height) to resize the panel to bigger. It worked perfectly in FF25, but not FF26.


Actual results:

Panel did resize in FF26, but content outside the original panel size is NOT displayed.  This happens on both Windows and Linux (I found another panel bug that only occurs on Windows not Linux, will file that one in a minute)


Expected results:

Panel should display entire content after resizing bigger.  Note that a workaround for the bug is to call hide and then show again, and content will display properly.

Updated

5 years ago
Component: Untriaged → General
Product: Firefox → Add-on SDK
Version: 26 Branch → unspecified
Matteo, do you have any ideas about this?
Flags: needinfo?(zer0)
Priority: -- → P2
Mingyi, your bug 950414 seems to have resolved itself in Firefox 27. Can you try this reproducing this bug in 27 as well?
Flags: needinfo?(mingyiliu)
(Reporter)

Comment 3

5 years ago
I did some testing and found:
1. This bug turns out also only happens when Hardward acceleration is enabled.
2. FF27 fixed this bug also.  So both Addon SDK panel bugs I reported for FF26 were fixed in FF27.  Guess we just need to wait for FF27 to be released.
Flags: needinfo?(mingyiliu)
I guess we can mark as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(zer0)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.