Disable JavaScript option doesn't work when DevTools are shown in a separate window

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
2 months ago

People

(Reporter: smokey101stair, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:
-Open DevTools
-Click Show in separate window
-Go to Toolbox Options
-Click Disable JavaScript

Actual Results:
Nothing

Expected Results:
Page reloads with JavaScript disabled.

I ran a mozregression all the way back to June.  Unfortunately, not a single build worked with disabling JavaScript while the DevTools were in a separate window. The Disable JavaScript option works just fine when the DevTools are docked in the browser.
(Reporter)

Updated

5 years ago
Summary: Disable JavaScript option doesn't work when DevTools are show in a separate window → Disable JavaScript option doesn't work when DevTools are shown in a separate window
As a way of debugging this, can you try this alternate STR:

-Open DevTools
-Click Show in separate window
- *close the devtools window, then open it again by hitting F12*
-Go to Toolbox Options
-Click Disable JavaScript

I'm wondering if this is similar to bug 909246, where we lose functionality after moving from one docked position to another, or to the separate window.
(Reporter)

Comment 2

5 years ago
Jeff, I tried your STR and I don't think that this bug is related to bug 909246. The Disable JavaScript option continues to work when the DevTools are switched from being docked at the bottom to being docked on the right.  It is only when the DevTools are in a separate window that the Disable JavaScript option is broken.  Though I was able to reproduce the problem you reported in bug 909246.
(Reporter)

Comment 3

5 years ago
I noticed that this was working in the most today's nightly, so I ran a mozregression and it looks like this was fixed in the 2013/12/19 nightly. Marking as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.