box-shadow with "transform: rotate" is not rendered properly

VERIFIED FIXED in Firefox 28

Status

()

defect
--
major
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: merihakar, Assigned: mattwoodrow)

Tracking

28 Branch
mozilla29
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox28 verified, firefox29 verified)

Details

Attachments

(3 attachments)

Starting from Firefox 28, box-shadow applied on a rotated element is not rendered properly. The rendering is not broken for all degree values but some of them.
I have encountered with the issue on css3test.com, where the shadows of the icon on the left is looking wrong. This is a bit ironic :)
Regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=53d55d2d0a25&tochange=6ecf0c4dfcbe

Bug 940845 lies in that range.
Blocks: 940845
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(matt.woodrow)
We were applying the transform twice when we decided to work in user space.
Attachment #8348370 - Flags: review?(roc)
Flags: needinfo?(matt.woodrow)
Assignee: nobody → matt.woodrow
https://hg.mozilla.org/mozilla-central/rev/2babdc3bdb94
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Duplicate of this bug: 951440
Reproduced in nightly 2013-12-15.
Verified fixed FF 29.0a1(2014-01-09), Win 7 x64
Status: RESOLVED → VERIFIED
Note that the problem still exists in Aurora, so application of this patch to aurora can be requested?
Comment on attachment 8348370 [details] [diff] [review]
Remove transform

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 940845
User impact if declined: malformed box-shadows in some pages
Testing completed (on m-c, etc.): landed for a while with no reported regressions
Risk to taking this patch (and alternatives if risky): low risk
String or IDL/UUID changes made by this patch: none
Attachment #8348370 - Flags: approval-mozilla-aurora?
Attachment #8348370 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Shadows with transform are looking fine in firefox aurora 28.0a2 (2014-01-25).
Doesn't work in Firefox 44.0a2, OSX El Capitan.

Box-shadow is shown for the original rotation of the element, it doesn't follow the transformation of the element.

Example: http://codepen.io/anon/pen/meGZbz
You need to log in before you can comment on or make changes to this bug.