The size reported by an applet is wrong

RESOLVED INVALID

Status

RESOLVED INVALID
17 years ago
8 years ago

People

(Reporter: jab, Assigned: joe.chou)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Try the following mini applet:
-------------------------------
import java.awt.*;
import java.applet.Applet;

public class mini extends Applet
{
  public void paint (Graphics g)
  {
     g.setColor(new Color(0));
     g.drawString("H:" + getSize().height, 5, 15);
     g.drawString("V: " + getSize().width, 5, 30);
  }
}
------------------------------------------------
in a html page with the following applet tag
--------------------------------------------------
<APPLET CODE="mini.class" WIDTH="49" HEIGHT="49">
</APPLET>
------------------------------------------------

The applet will return a height = 49 which is correct but in my setup it will 
return a width = 112.

Comment 1

17 years ago
Over to Plug-Ins.
Assignee: asa → av
Component: Browser-General → Plug-ins
QA Contact: doronr → shrir

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
WFM with fresh builds on Linux and Solaris 2.8 (java 1.3.1)
Reportes, could you please try it again? Thanks.
BTW, what java version you're using?

Andrei, should component be OJI?

Comment 3

17 years ago
Likely. Reassigning for evaluation.
Component: Plug-ins → OJI

Comment 4

17 years ago
-->default owner.
Assignee: av → joe.chou
QA Contact: shrir → pmac

Comment 5

17 years ago
Whew, reproduced this on Win98 (but with old 0.9.7 release and java 1.3.1).
I noticed that applet prints V: 112 for any width value less or equal
112. For width attr. value > 112 applet displays correct values. Wierd!

Comment 6

17 years ago
removing myself from cc:

Comment 7

16 years ago
I use 
Netscape 6.2.2
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4.1) Gecko/20020314
and 
Java(TM) Plug-in: Version 1.4.0
Using JRE version 1.4.0 Java HotSpot(TM) Client VM

test this bug, this bug don't happen, the H and V display correctly: 49
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 8

16 years ago
cc to me

Updated

16 years ago
QA Contact: pmac → petersen

Comment 9

16 years ago
*** Bug 100350 has been marked as a duplicate of this bug. ***

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.