Closed Bug 950505 Opened 7 years ago Closed 7 years ago

Build content/media/wmf in unified mode

Categories

(Core :: Audio/Video, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: ehsan, Assigned: ehsan)

References

Details

Attachments

(2 files)

No description provided.
Blocks: unified
Component: General → Video/Audio
Attachment #8347786 - Flags: review?(roc)
Assignee: nobody → ehsan
Backed out:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e353c1d40586

This caused my local Windows build to fail because many of the source files #define LOG which causes duplicate macro warnings which get treated as errors with ac_add_options --enable-warnings-as-errors. Apparently our Windows builders don't have ac_add_options --enable-warnings-as-errors, so this showed up only locally.
https://hg.mozilla.org/mozilla-central/rev/1566a2e95c3b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Brian Smith (:briansmith, was :bsmith; Please NEEDINFO? me if you want a response) from comment #3)
> Backed out:
> https://hg.mozilla.org/integration/mozilla-inbound/rev/e353c1d40586
> 
> This caused my local Windows build to fail because many of the source files
> #define LOG which causes duplicate macro warnings which get treated as
> errors with ac_add_options --enable-warnings-as-errors. Apparently our
> Windows builders don't have ac_add_options --enable-warnings-as-errors, so
> this showed up only locally.

It would be nice if you at least provided a build log when backing out something that has not turned our builds red, especially since that your premise is not correct:

http://mxr.mozilla.org/mozilla-central/source/browser/config/mozconfigs/win32/debug#20
http://mxr.mozilla.org/mozilla-central/source/browser/config/mozconfigs/win32/common-opt#28
Flags: needinfo?(brian)
Also helpful would be your compiler version, your mozconfig, etc, because I can't reproduce your problem.
FWIW I'm planning to reland these patches later today, I've done local debug and opt builds and cannot reproduce your problem.
backout changeset was included in m-c https://tbpl.mozilla.org/?rev=832ef0e8771e
Attached file .mozconfig
Flags: needinfo?(brian)
(In reply to comment #10)
> Created attachment 8348216 [details]
>   --> https://bugzilla.mozilla.org/attachment.cgi?id=8348216&action=edit
> .mozconfig

I bet --enable-logging is causing this.  Please file a new bug.  Thanks!
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #11)
> (In reply to comment #10)
> > Created attachment 8348216 [details]
> >   --> https://bugzilla.mozilla.org/attachment.cgi?id=8348216&action=edit
> > .mozconfig
> 
> I bet --enable-logging is causing this.  Please file a new bug.  Thanks!

Comment #3 explains very clearly that the problem is with LOG. Why did you check these patches back in knowing that there is a bug with them, and after the bug was clearly pointed out, and without giving me even 24 hours to reply to your request? Lots of people build with --enable-logging and it isn't like I backed out the patches for fun.
(In reply to Brian Smith (:briansmith, was :bsmith; Please NEEDINFO? me if you want a response) from comment #12)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #11)
> > (In reply to comment #10)
> > > Created attachment 8348216 [details]
> > >   --> https://bugzilla.mozilla.org/attachment.cgi?id=8348216&action=edit
> > > .mozconfig
> > 
> > I bet --enable-logging is causing this.  Please file a new bug.  Thanks!
> 
> Comment #3 explains very clearly that the problem is with LOG. Why did you
> check these patches back in knowing that there is a bug with them, and after
> the bug was clearly pointed out, and without giving me even 24 hours to
> reply to your request? Lots of people build with --enable-logging and it
> isn't like I backed out the patches for fun.

Because we don't backout patches which break --enable-warnings-as-errors builds on non-standard configurations.  Also, the bug was not clearly pointed out in comment 3, and I did go through the trouble of doing a --enable-warnings-as-errors debug and opt build locally, both of which succeeded.
https://hg.mozilla.org/mozilla-central/rev/ac40b01fd56b
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.