All users were logged out of Bugzilla on October 13th, 2018

webelements.com - "Login" button forum is mixed with text

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: aufbau01, Assigned: karnaze)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Steps to reproduce:
1. Go to http://www.webelements.com/board/.
2. Look at the login box on the right.

Actual result: the "Login" button is part of a block of text explaining how to
create a new account.

Expected result: the "Login" button should be under the block of text, with a
blank line in between, like in Opera and Internet Explorer.

Comment 1

17 years ago
INVALID I think.. page uses HTML 4.01.
Er.... except a form is still a block box in both quirks and strict mode, right?

Comment 3

17 years ago
Hmm.. well then could it be the fact that the page hardly ever uses quotes 
around the attribute parameters?
This looks like a valid layout bug to me, pending a reduced testcase...
Assignee: rods → karnaze
Status: UNCONFIRMED → NEW
Component: HTML Form Controls → Layout
Ever confirmed: true
Keywords: qawanted
QA Contact: madhur → petersen
Hah! Problem is due to misnested center and font tags.  In fact, if you just
move the </center> from the end of the text to just before </form> and leave the
font where it is, form acts like a block, as usual.  This may well be a content
model/parser problem.

Comment 6

17 years ago
After some testing, a few wrong paths, we've worked out that this is not a
layout issue, but an evangelism issue. The layout errors occured due to badly
nested tags, (principally the <form></form> tags), causing a <br> to be inserted
in IE, which wasn't present in Mozilla. 

Mozilla seems to be more standards correct, so this is an evangelism issue.

Attached a test case document to demonstrate the issue.
Component: Layout → African
Keywords: qawanted
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 7

17 years ago
Created attachment 56458 [details]
simplest reproducible test case.

Comment 8

17 years ago
looks the same for me on both IE and 6.x.  WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

17 years ago
The testcase looks the same in IE and Mozilla (it's wrong in both), but
http://www.webelements.com/board/ still looks fine in IE and bad in Mozilla.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

17 years ago
Summary: "Login" button at webelements.com forum is mixed with text → webelements.com - "Login" button forum is mixed with text
(Reporter)

Comment 10

17 years ago
The site worksforme with build 2002012008.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Component: African → English: Non-US
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.