If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

See memory leaks after using camera for a long time

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Camera
--
major
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: bhargavg1, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PRISM:580024][MemShrink:P2])

(Reporter)

Description

4 years ago
After using camera for taking snapshots for a long time see that the camera app becomes unresponsive. 

From the memory reports see that large chunks of data is leaked. See following for more information

https://bugzilla.mozilla.org/show_bug.cgi?id=941789#c16

+++ This bug was initially created as a clone of Bug #941789 +++

Upon running camera tests over a period of time see that there is a crash in OMXCodecProxy with the following signature

[@ android::MediaResourceManagerService::cancelClientLocked(android::spandroid::IBinder const&) | android::MediaResourceManagerService::cancelClient(android::spandroid::IMediaResourceManagerClient const&) | android::OMXCodecProxy::~OMXCodecProxy | android::OMXCodecProxy::~OMXCodecProxy ]

+++ This bug was initially created as a clone of Bug #937849 +++

When using camera app in overnight tests runs see that there is a crash in mediaserver.

The root cause seems that the camera app is passing bad data to the mediaserver somehow.

These seems to be part of series of camera app bugs

bug 937758, bug 924039
(Reporter)

Updated

4 years ago
Crash Signature: [@ android::MediaResourceManagerService::cancelClientLocked(android::spandroid::IBinder const&) | android::MediaResourceManagerService::cancelClient(android::spandroid::IMediaResourceManagerClient const&) | android::OMXCodecProxy::~OMXCodecProxy | …
STR?
1. open camera
2. press shutter button to take photo
3. goto 2 ... ?
Flags: needinfo?(bhargavg1)
(Reporter)

Comment 2

4 years ago
(In reply to Mike Habicher [:mikeh] from comment #1)
> STR?
> 1. open camera
> 2. press shutter button to take photo
> 3. goto 2 ... ?

more similar to steps as in earlier bug, https://bugzilla.mozilla.org/show_bug.cgi?id=924036#c8
Flags: needinfo?(bhargavg1)
Pasting bug 924036 comment 8 here for completeness:

The test procedure being followed,

1. Make call and end the call -
2. Open camera and take pictures. (Take for 5 snapshots, will vary this number usually, it will be between 5 to 10)
3. Open camcorder and record videos.
4. Open music and play music.
5. Now open video and play video.

Steps from 1 -> 5 run continuously overnight
Do we know if this is still reproducible with the full steps provided?
Flags: needinfo?(bhargavg1)
(Reporter)

Comment 5

4 years ago
havent checked this on the latest builds. Not sure if there was any specific fix for this issue
Flags: needinfo?(bhargavg1)
Is media server crash caused by ion memory alloc failed?
we also have this issue.
Is this bug obsolete?
Flags: needinfo?(mhabicher)
Bhargav, see comment 7.
Flags: needinfo?(mhabicher) → needinfo?(bhargavg1)
(Reporter)

Comment 9

3 years ago
(In reply to Mike Habicher [:mikeh] from comment #8)
> Bhargav, see comment 7.

We raised this as part of v1.2 and camera has undergone enough overhaul since, dont think we need this anymore.

But we do still continue to have leaks on latest code as well tracked through Bug 1029856

Will mark this as "WONTFIX" guess that's the right state
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bhargavg1)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.