scratchpad toggle comment corrupts URLs and string values

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
8 months ago

People

(Reporter: anaran, Unassigned)

Tracking

29 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20131214040201

Steps to reproduce:

Tried commenting out lines in Scratchpad with Ctrl-/, here's a testcase:

https://bugzilla.mozilla.org/show_bug.cgi?id=868828
"https://bugzilla.mozilla.org/show_bug.cgi?id=868828"
'https://bugzilla.mozilla.org/show_bug.cgi?id=868828'



Actual results:

https:bugzilla.mozilla.org/show_bug.cgi?id=868828
"https:bugzilla.mozilla.org/show_bug.cgi?id=868828"
'https:bugzilla.mozilla.org/show_bug.cgi?id=868828'



Expected results:

// https://bugzilla.mozilla.org/show_bug.cgi?id=868828
// "https://bugzilla.mozilla.org/show_bug.cgi?id=868828"
// 'https://bugzilla.mozilla.org/show_bug.cgi?id=868828'

Google Chrome had the same symptoms which got fixed recently:

https://code.google.com/p/chromium/issues/detail?id=321748

Updated

5 years ago
Component: Untriaged → Developer Tools: Scratchpad
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868828
(Reporter)

Comment 2

5 years ago
This is not a duplicate of bug 868828!

This bug 950632 is about the fact that JS code is not parsed correctly the determine single-line comment starters.

It does not matter for this incorrect behavior that it happens to be triggered by Ctrl-/.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

5 years ago
Toggling the sample comment lines provided in this bug report now work correctly for me in nightly firefox on windows xp.


navigator.userAgent
"Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0"
navigator.buildID
"20140201074923"

(On my German keyboard I have to first switch to the English locale, then use Ctrl+- to toggle comments.)
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME

Updated

8 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.