Bing search icon is larger than other default search icons

VERIFIED FIXED in Firefox 27

Status

()

Firefox for Android
General
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: Paul [pwd], Assigned: Margaret)

Tracking

Trunk
Firefox 29
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27 verified, firefox28+ verified, firefox29+ verified, fennec27+)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131209055637

Steps to reproduce:

Everything else is around the same size and then there's the Bing icon which looks like it was shoehorned in there. It just doesn't match the standard of the rest of Fennec. We should either reduce it to match the rest of the search icons or find an alternative bing icon. But  what is there now surely can't stay.
(Reporter)

Updated

4 years ago
Blocks: 946802
OS: Linux → Android
Hardware: x86 → ARM
It's the exact same 16x16 size icon as the others.
(Reporter)

Comment 2

4 years ago
Created attachment 8348131 [details]
Screenshot_2013-12-16-17-01-48.png

Maybe the image is, but the mass of the Bing logo is vastly different to that of the rest.
The icon inside the file is 70px, but using the product is exactly the same size of other icons (which I think is 32px on mobile).

What language is your phone using?
(Assignee)

Comment 4

4 years ago
It looks like this problem is caused by the 70x70 icon. In bug 946802, I just used the image Microsoft gave us, but we should probably update it to a 32x32 icon to be consistent with the rest of the default icons.

Which phone are you using? This is likely caused by the fact that you have a higher resolution screen that the phones that other people are using to test, so the image isn't being scaled down at all.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Bing search icon is too large, it lowers the quality of our product → Bing search icon is larger than other default search icons
(Reporter)

Comment 5

4 years ago
(In reply to Francesco Lodolo [:flod] from comment #3)
> What language is your phone using?
English (United Kingdom)


(In reply to :Margaret Leibovic from comment #4)
> Which phone are you using? This is likely caused by the fact that you have a
> higher resolution screen that the phones that other people are using to
> test, so the image isn't being scaled down at all.

Ah, that makes sense. I'm using a HTC One (M7ul) with a 4.7 inch (120 mm) Super LCD 3 with RGB matrix
1920×1080p pixels (16:9 Aspect ratio) (468 ppi) display*

*At least according to Wikipedia.
(In reply to Paul [sabret00the] from comment #5)
> (In reply to Francesco Lodolo [:flod] from comment #3)
> > What language is your phone using?
> English (United Kingdom)

I thought you were hitting a bug on the localized build, then I realized Google is not locale specific.
Margaret/Ian, what should be done here?
Man. It's like every screenshot I see, our search provider icons are a different size. :( They should be scaled the same as the globe icons in Paul's screenshot. So in this case, it looks like Bing is correct and all the others are off. http://cl.ly/image/3b091Y1c3I03

Seems like bug 938165 might be related? https://bug938165.bugzilla.mozilla.org/attachment.cgi?id=831551
(Assignee)

Comment 9

4 years ago
(In reply to Ian Barlow (:ibarlow) from comment #8)
> Man. It's like every screenshot I see, our search provider icons are a
> different size. :( They should be scaled the same as the globe icons in
> Paul's screenshot. So in this case, it looks like Bing is correct and all
> the others are off. http://cl.ly/image/3b091Y1c3I03

For the globe icon we have multiple resources for different screen resolutions, giving us what we want. For bing, we have a 70x70 icon (provided by Microsoft), which gets scaled down if necessary. For all the other search providers, we have a 32x32 icon, which can't get scaled up any more, so we end up with that excess whitespace around the icon.

As a quick solution for consistency, we could replace the current bing icon with a 32x32 icon. Or we could also try including larger icons for all the other default search providers. However, this won't fix the general issue with scaling smaller favicons.

It sounds like bug 938165 does describe the actual scaling issue that's causing us to have this in-between state where an icon isn't small enough to get a dominant color background, but isn't large enough to take up the whole favicon view space.
(In reply to :Margaret Leibovic from comment #9)

> As a quick solution for consistency, we could replace the current bing icon
> with a 32x32 icon. 

Let's start with that. 

> Or we could also try including larger icons for all the
> other default search providers. 

And then we can move to this, when we are able to source larger icons. 

> However, this won't fix the general issue
> with scaling smaller favicons.

And we can keep chipping away at this, maybe forever ;)
Bing 32x32 icon: http://cl.ly/image/2p2c332k0u0K
(Assignee)

Comment 12

4 years ago
(In reply to Ian Barlow (:ibarlow) from comment #10)
> (In reply to :Margaret Leibovic from comment #9)
> 
> > As a quick solution for consistency, we could replace the current bing icon
> > with a 32x32 icon. 
> 
> Let's start with that. 

Sounds good, I can do that in this bug.

> > Or we could also try including larger icons for all the
> > other default search providers. 
> 
> And then we can move to this, when we are able to source larger icons. 

We can file a follow-up for that.

> > However, this won't fix the general issue
> > with scaling smaller favicons.
> 
> And we can keep chipping away at this, maybe forever ;)

We can do this in bug 938165. I feel like we just need to sit down and sift through the matrix of different icon sizes and screen resolutions to figure out the best solution.
Assignee: nobody → margaret.leibovic
(Assignee)

Comment 13

4 years ago
Created attachment 8356172 [details] [diff] [review]
Update Bing icon to 32x32

This makes me kinda depressed because the Bing icon is now slightly blurry like the other search icons (testing on a Nexus 4), but at least that's consistent.

We should see if we can get a variety of icon sizes in a follow-up bug, or at least default to including larger icons for all search engines.
Attachment #8356172 - Flags: review?(mark.finkle)
Attachment #8356172 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 14

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/c187ed71e2f2
(Assignee)

Comment 15

4 years ago
This new Bing icon landed in 27, so I think we should try to uplift this fix.
tracking-fennec: --- → ?
I recall search engines having L10N impact. Unless this is EN-us only. Setting tracking-firefox flags to loop relman in as well.
status-firefox26: --- → unaffected
status-firefox27: --- → affected
status-firefox28: --- → affected
status-firefox29: --- → affected
tracking-firefox27: --- → ?
tracking-firefox28: --- → ?
(In reply to Kevin Brosnan [:kbrosnan] from comment #16)
> I recall search engines having L10N impact. Unless this is EN-us only.
> Setting tracking-firefox flags to loop relman in as well.

Bing is a good one: redirect is server side, all locales using Bing rely on the en-US xml file. Once en-US is fixed, l10n is good.
https://hg.mozilla.org/mozilla-central/rev/c187ed71e2f2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
(Assignee)

Comment 19

4 years ago
Comment on attachment 8356172 [details] [diff] [review]
Update Bing icon to 32x32

[Approval Request Comment]
Bug caused by (feature/regressing bug #): this was introduced when we updated the bing icon in bug 946802 
User impact if declined: built-in search engine icons have inconsistent sizes
Testing completed (on m-c, etc.): just landed on m-c
Risk to taking this patch (and alternatives if risky): low-risk, changing an icon
String or IDL/UUID changes made by this patch: none
Attachment #8356172 - Flags: approval-mozilla-beta?
Attachment #8356172 - Flags: approval-mozilla-aurora?

Updated

4 years ago
tracking-firefox27: ? → ---
tracking-firefox28: ? → +
tracking-firefox29: --- → +

Updated

4 years ago
status-firefox29: affected → fixed
Comment on attachment 8356172 [details] [diff] [review]
Update Bing icon to 32x32

Given it is low risk and no l10n concerns  per comment #17 approving on branches.
Attachment #8356172 - Flags: approval-mozilla-beta?
Attachment #8356172 - Flags: approval-mozilla-beta+
Attachment #8356172 - Flags: approval-mozilla-aurora?
Attachment #8356172 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/2c8f8683bd0d
https://hg.mozilla.org/releases/mozilla-beta/rev/c14b5cb7d00e
status-firefox27: affected → fixed
status-firefox28: affected → fixed
tracking-fennec: ? → 27+

Comment 22

4 years ago
Build: Nightly 29.0a1 2014-01-10 and Aurora 28.0a2 2014-01-10
Device: Galaxy Nexus / HTC Desire HD
OS: Android 4.3/2.3.1

The Bing icon it the same size as google, yahoo (also with solid background) amazon, wikipedia and twitter.
Setting the Fx 29 an Fx 28 flags to fixed. I will check for bet when 27.0b6 will be out.
status-firefox28: fixed → verified
status-firefox29: fixed → verified

Comment 23

4 years ago
Verified as fixed in  build: 27 beta 6;
Device: Google Nexus 7 (Android 4.4.2);
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
You need to log in before you can comment on or make changes to this bug.