[CostControl] Graphic isn't show data correctly

RESOLVED INCOMPLETE

Status

Firefox OS
Gaia::Cost Control
RESOLVED INCOMPLETE
4 years ago
4 years ago

People

(Reporter: lolimartinezcr, Assigned: mai)

Tracking

({regression})

unspecified
x86
Windows 7
regression

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Whiteboard: burirun1.3-1)

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8348117 [details]
2013-12-15-23-58-14.png

Tested:
12/17
Hamachi
Gecko 12e9915
Gaia 888f9df

Steps:
1. Navigate in Internet, and you use wifi.
2. Tap in usage aplication.
3. Tap in Internet tap.

Expected: 
Graphic with date visibles and dot final to bar

Actual:
Graphic with date not visible and not dot final to bar. (See attached)
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 1.3?
Whiteboard: burirun1.3-1
(Reporter)

Comment 1

4 years ago
Created attachment 8348118 [details]
2013-12-16-23-59-21.png
(Reporter)

Comment 2

4 years ago
Created attachment 8348119 [details]
2013-12-13-10-20-37.png

Updated

4 years ago
Keywords: regression, regressionwindow-wanted
Can we confirm this doesn't reproduce on 1.2?
Keywords: regressionwindow-wanted → qawanted

Comment 4

4 years ago
Possible dupe to bug 928620? I know I've seen this issue reported before.
triage: 1.3+ regrssion
blocking-b2g: 1.3? → 1.3+

Updated

4 years ago
QA Contact: gbennett
I was unable to reproduce the actual results using STRs in Comment 0 on Buri v1.2 COM RIL or today's Buri v1.3 COM RIL.  I also do not show the tabs for Cost Control that are shown in attachment 8348117 [details] in either 1.2 or 1.3.

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131219004002
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/7958c38c7afd
Gaia: c82c957e9d4078cd4043de6b7d21a2667a73adf7
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: 20131115

Environmental Variables
Device: Buri v1.3 COM RIL
Build ID: 20131219004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/809aabadac6d
Gaia: a99249a7fdf9f20850d98a9a222385676d472362
Platform Version: 28.0a2
RIL Version: 01.02.00.019.102 
Firmware Version: 20131115
Keywords: qawanted
QA Contact: gbennett
Assignee: nobody → mri
(Reporter)

Comment 7

4 years ago
Tested again:
12/20
eng
1.3
gecko ba8ed3a
gaia 5772887
(Reporter)

Comment 8

4 years ago
Created attachment 8350568 [details]
2013-12-02-00-05-48.png
(Reporter)

Comment 9

4 years ago
Comment on attachment 8348119 [details]
2013-12-13-10-20-37.png

This is correct

Comment 10

4 years ago
I am unable to reproduce this issue using the STR from comment 0. 

However I can get this issue to reproduce using another set of STR:

1) Update Buri to Master M-C (1.4) MOZ RIL BuildID: 20131223040210
2) Launch the Usage app
3) Set the report reset date to one day later
4) Navigate to the Settings app
5) Manually set the time to 11:58pm
6) Use some data for a moment
7) At 12:00am, navigate to the Usage app; observe report has been reset
8) Navigate to the Settings app
9) Manually set the Date to a few days earlier
10) Navigate to the Usage app

With the STR above, I can get this issue to reproduce on the 12/23 1.2 and 1.3 builds as well.

Environmental Variables:
Device: Buri Master M-C (1.4) MOZ RIL
BuildID: 20131223040210
Gaia: 5c4bb7e9dcdf6f168701508922c232a67cd8ea1f
Gecko: c0f85061c7d3
Version: 29.0a1
Firmware Version: 20131115
The comment above sounds like a different bug - can file a different bug for that? As for this bug, we are going to need better str to move forward.
Whiteboard: burirun1.3-1 → burirun1.3-1 [closeme 12/30/2013]

Comment 12

4 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
Whiteboard: burirun1.3-1 [closeme 12/30/2013] → burirun1.3-1
You need to log in before you can comment on or make changes to this bug.