If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

In the App Manager, adding a break point scroll the page up

RESOLVED FIXED in Firefox 29

Status

()

Firefox
Developer Tools: WebIDE
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: paul, Assigned: paul)

Tracking

Trunk
Firefox 29
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

4 years ago
Assignee: nobody → paul
See Also: → bug 940296
(Assignee)

Comment 1

4 years ago
This only happens when the toolbox is *inside* the app manager (in a custom host).
(Assignee)

Comment 2

4 years ago
Created attachment 8348211 [details] [diff] [review]
v1

We called scrollIntoView to make sure the toolbox button was visible in the app manager. But scrollIntoView also scrolls the inner documents, like the toolbox, which messes with everything.

scrollIntoView in the app manager tabs was handy, but it's really not that useful.

And this bug blocks many people (gaia dev using the debugger).
Attachment #8348211 - Flags: review?(rcampbell)
Comment on attachment 8348211 [details] [diff] [review]
v1

Review of attachment 8348211 [details] [diff] [review]:
-----------------------------------------------------------------

alrighty then.
Attachment #8348211 - Flags: review?(rcampbell) → review+
(Assignee)

Comment 4

4 years ago
I just want to add that hunting this bug was epic and hard. I failed to figure out what was wrong, but optimizer, blindly, figured out the whole story. I was impressed.
Keywords: checkin-needed
(Assignee)

Updated

4 years ago
Duplicate of this bug: 940296
https://hg.mozilla.org/integration/fx-team/rev/1627332b2e7f
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/1627332b2e7f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
(In reply to Paul Rouget [:paul] from comment #4)
> I just want to add that hunting this bug was epic and hard. I failed to
> figure out what was wrong, but optimizer, blindly, figured out the whole
> story. I was impressed.

I am putting this on my card : "Paul is impressed" :)
You need to log in before you can comment on or make changes to this bug.