The links on the Event Reference page appear to be broken

RESOLVED FIXED

Status

Developer Documentation
General
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Doug Rubino, Assigned: udeepak010, NeedInfo)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

Repro:
1) Visit the Event Reference page: 
https://developer.mozilla.org/en-US/docs/Web/Reference/Events
2) Click on a standard event (blur for instance):
https://developer.mozilla.org/en-US/docs/Web/API/GlobalEventHandlers.blur
Expected: The page loads and shows me information about the event.
Actual: I receive a 404 not found error, prompting me to file a bug (which I am doing).

Notes: I am using Windows 8/Chrome (not Canary), though I doubt this will be needed to repro.


Actual results:

I receive a 404 not found error, prompting me to file a bug (which I am doing).


Expected results:

The page loads and shows me information about the event.
Sheppy: you updated the macros Event() to point to the non-existant GlobalEventReference.xyz.

Any reason why?

We have pages for quite a lot of these events but they are not where the link point.
Flags: needinfo?(eshepherd)
I made that change because a lot of those pages were moved to GlobalEventHandler.x. But apparently not all of them. We need to figure out what the hell happened here; someone did something wrong. Maybe a couple of people, including me.
Flags: needinfo?(eshepherd)
Some on{blur,...} properties are on the GlobalEventHandler HTML interface. But not all. I moved these as they are there.

The GlobalEventHandler interface is used by several interfaces, hence its creation in HTML.

But that should have no impact on {{event}} as this doesn't link to the onXYZ properties but to the event themselves.

Am I wrong?
(Assignee)

Comment 4

3 years ago
Doug Rubino: The links are working properly now. Could you check it again in your browser and inform us whether the bug is solved?
Flags: needinfo?(doug.rubino)
(Assignee)

Updated

3 years ago
Assignee: eshepherd → udeepak010
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Oh yes, I fixed the link one or two months ago and forgot to close the bug here. It was in an awful state. Thanks very much for the report Doug.
You need to log in before you can comment on or make changes to this bug.