Want "List Item Properties" to appear for list item context menu

VERIFIED FIXED in mozilla0.9.5

Status

()

P5
enhancement
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: neil, Assigned: cmanske)

Tracking

Trunk
mozilla0.9.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I'm filing this as an enhancement as I don't want to see the item removed.

If you left-click a bullet it selects the list item, and the context and format
menus allow you to access the advanced property editor for list items.
Unfortunately Editor names the menuitem " Properties..." but I would prefer
"List Item Properties" or even "List Item Advanced Properties".
(Reporter)

Comment 1

17 years ago
Created attachment 45642 [details] [diff] [review]
Proposed patch
(Reporter)

Updated

17 years ago
Keywords: patch, polish, review, ui

Updated

17 years ago
Assignee: beppe → cmanske
Priority: -- → P5
Target Milestone: --- → Future

Comment 2

17 years ago
future

Comment 3

17 years ago
r=brade
OS: Windows 95 → All
Hardware: PC → All
Target Milestone: Future → mozilla0.9.5
(Assignee)

Comment 4

17 years ago
Looks good to me as well.
Status: NEW → ASSIGNED
Whiteboard: FIX IN HAND need sr=

Comment 5

17 years ago
sr=kin@netscape.com
Whiteboard: FIX IN HAND need sr= → FIX IN HAND, reviewed

Comment 6

17 years ago
*** Bug 95664 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
*** Bug 95662 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
when this is fixed check the label of the menu item and make sure its List
Props. also check to see if it goes to List props and not Advanced.
(Reporter)

Comment 9

17 years ago
sujay, there isn't a list item properties dialog (yet?), this bug was just to
fix the strange label that appears on the context menu.

Comment 10

17 years ago
Yes, there is a list properties dialog.  Look under Format | List menu.  :-)
(Assignee)

Comment 11

17 years ago
In most cases, like when you context-click on a list item, you will see 
"List Properties" in the context menu. Same if caret or partial selection is in a 
list item and you use Format menu. The simpler "List Properties" dialog is 
launched when you use that command. This fix is for the special case where
the List Item is the only thing selected, which you get most easily when you 
click on the list item bullet. In that case (with this fix) you will get
"List Item Properties" and launch the Advanced Edit dialog. Most users probably
won't see this.
(Assignee)

Comment 12

17 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: patch, polish, review, ui
Resolution: --- → FIXED
Whiteboard: FIX IN HAND, reviewed
(Reporter)

Comment 13

17 years ago
Looks good to me.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.